Mobile broadband is lost after suspend

After suspend and wake up, the mobile broadband device is lost.

After reboot, I can see
cdc-wdm2 gsm disconnected --
via command nmcli dev. And cdc-wdm2 is shown in /dev

After suspend and wake up, the above line is missing via nmcli dev, and cdc-wdm2 is not shown in /dev

Using Zorin OS 16.2
Using ThinkPad T14 Gen3 (12th Gen Intel® Core™ i5-1240P × 16)

Anyone could help? Thanks in advance.

1 Like

This has been an issue on wifi cards as well. If you don't have TLP & TLPUI installed, you can use apt in the terminal to quickly install both, sudo apt install tlp tlpui. You can go in and either turn off power saving for the broadband card or you will have to restart. I'm not sure of any other fixes at this time.

Since suspend releases hardware and the services that manage them prior to powering down, there may be a script you can set up that allows the restart of the service upon wake, but you will have to search this. Most individuals don't have a cellular card in the laptop. You are the only one who can test these things and find a solution. I can't replicate this because i don't have that hardware.

Thanks for the advice. I tried tlp/tlpui but did not find options about power saving the mobile broadband card.

However, I found if suspend and wake up with AC power, the mobile broadband goes back. There must be some options.

Gday @tanghao , You could try changing the usb ports power setting in BIOS,
To allow power to usb ports while hibernating,

Yes Ocka, I saw an option saying allow usb port charging when sleep, while it was already set.

Then I find when on battery power, the first time it wakes up, the LTE is gone; but the second time it is back. Another thing, every time it wakes up the screen is off, while the screen is on on other laptops.

Finally I seem to get it. There is "sleep mode" option in BIOS. I changed it from "Linux S3" to "Windows and Linux", and the problem does not reproduce now.

Thanks again @337harvey and @Ocka

2 Likes

If you consider your last post was the Solution, please click on the "..." under your post and mark it as "Solution". Thanks