Monitor timeout sometimes drops to 5 secs after sleep

I have my screen timeout set to 15 minutes. After I have awakened my tower a few times, the screen times out after about 5 seconds. I reboot to reset it. I do not know if there is a fixed set of awakenings that cause it. Is there a fix?
Zorin OS 15.3 Ultimate
ASUS Prime B450M-A motherboard
AMD Ryzen cpu
Zotac nvidia GEFORCE GT 710

If Aravisian’s solution here Remove blank screen after inactivity doesn’t work, then try zabadabadoo’s recommendation (marked as solution on same thread).

Thanks, carmar. I had found this solution, Caffeine, but the description says that it keeps the screen on. I don’t want to disable the timeout. I just want it to be longer than 5 secs.

@JimH What do you actually see when screen times out?
The timeout could either be screensaver or power management setting.
I assume by reading you have a tower PC not laptop with battery, but worth having a look there to see if anything not as it should be.

Yes Caffeine fools the system with simulated mouse activity to prevent timeout. Not what you are asking.
5 seconds is a crazy short timeout and not a system default I would expect.

Yes, I have a tower. In Settings under Power Saving I have set Blank Screen to 15 mins with automatic sleep and ‘Nothing’ for power button. I believe that a package must be installed in order to have a screen saver. At least, I can find no settings for one. I did not install nor do I want a screen saver.

Can you try Alt+F2 and type dconf-editor? If that doesn’t work, sudo apt install dconf-tools in terminal and again try the Alt+F2.
In the new window, navigate to /org/gnome/desktop/screensaver and toggle idle-activation-enabled OFF. Close and see if your timeout is disabled. Then go back and toggle ON again and see if the 5 seconds problem has gone away.

Ok. I have installed dconf utilities. The idle-activation-enabled was enabled. I left it enabled in order to see if the problem recurs. I do not know how to trigger the problem. I just have to wait to see if it occurs again. I’m a retired 72 old life-time programmer. I use my machine much of the day most days. It goes to sleep after 1/2 hour of inactivity which occurs an unpredictable number of times per day. The symptom only appears after multiple sleep occurrences. I do not know how many or even if it is always after the same number. On second thought, that doesn’t work. I must disable it. Then, if the symptom does not recur after a week or so, it will likely never recur. I’ll post again when it occurs or after a week of non-occurrence.

Ok. I did the screensaver disable as I already reported. Just now, I had to leave the machine long enough for the screen to go blank, but not long enough to be logged off. I have not booted the machine since yesterday. When I hit a key in order to bring the screen back on, I was in the quick timeout problem. I timed it this time. It is 15 seconds, not 5. I timed it several times. It is always exactly 15 seconds. Just for the heck of it, I will now usine dconf to re-enable the screensaver and then disable it again. Please standby … Result: no change. I will now reboot to eliminate this major annoyance.

New clue: Instead of rebooting as I said I would do, I logged out and back in. The quick timeout is gone. I am back to the 15 minute timeout.

1 Like

New clue: I just awoke the machine to find the screen turning off after 15 secs. I logged off. The screen that was displayed is the one with a digital clock showing. When I tried to log in again, the machine ignored the keyboard. The mouse pointer still responded to the mouse. After trying a number of hopeless keys such as ctrl-c, ctrl-d, esc, alt-f2 … I paused for a few minutes. Then I pressed enter again and this time I got the log in screen. After logging in, the screen timeout was back to 15 mins.

Out of curiosity, can you post the result of xinput ?

jim@jims:~$ xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ SEMICCHIP USB Mouse id=8 [slave pointer (2)]
⎜ ↳ Kingston HyperX Alloy FPS RGB Mouse id=11 [slave pointer (2)]
⎜ ↳ Kingston HyperX Alloy FPS RGB Consumer Control id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ Kingston HyperX Alloy FPS RGB id=9 [slave keyboard (3)]
↳ Kingston HyperX Alloy FPS RGB id=10 [slave keyboard (3)]
↳ Kingston HyperX Alloy FPS RGB System Control id=12 [slave keyboard (3)]
↳ Kingston HyperX Alloy FPS RGB Keyboard id=14 [slave keyboard (3)]
↳ Eee PC WMI hotkeys id=15 [slave keyboard (3)]
↳ Kingston HyperX Alloy FPS RGB Consumer Control id=16 [slave keyboard (3)]

Thanks. Nothing off with the keyboard.

This was the first time that there was no indication of keyboard input after logging out and back in. I’ve continued using the system since then. It appears to be functioning normally. Although I don’t think it had anything to do with this, the system was crashed yesterday. The battery in my UPS has gone bad and there was a power failure. The system started back up without any apparent problems.

Have you looked at:
Settings>Privacy>Screen Lock. Do you have a timeout set for that?
(See @swarfendor437 unofficial manual page 65.)

The screen with digital clock is the Zorin “lockscreen”. You should be able normally to swipe up with left click mouse to get to your login screen from that without other key combinations.

Under org/gnome/desktop/screensaver -> Lock Enabled is OFF.
and idle-activation-enabled is also OFF. Settings->Privacy->Screen Lock also says OFF.

I don’t understand. Is no one else having this issue? It is very frustrating. It has happened twice today. The last time after I logged off and back on to stop the rapid timeout, just now, when what may have been the desktop appeared, it lacked all of the icons. This happens once in awhile. The win7-esque taskbar was present and normal and the wallpaper I selected, palms, was there … but no icons. And the popup menu from the right mouse button is different whenever this happens. Instead of allowing me to start a terminal session, it has only 3 entries: Display Settings, Settings and one other that I’ve forgotten. I decided to work with it this way to see if it seemed otherwise normal. It does except for chrome. Usually, the chrome browser re-opens all of the tabs I had last open. This time it did not. Maybe I should be posting these things as potential bugs. I always hesitate to do that because it is so easy to thing something is a bug when it isn’t. This machine is practically brand new and seems otherwise rock solid.

Have you tried removing your .XAuthority file in your home folder?
Then restart your display manager (For me on XFCE Zorin Lite or Ultimate Lite, it is lightdm. On Gnome, Core and Ultimate), it is gdm

sudo systemctl restart gdm.service


sudo systemctl restart lightdm

Afterwards, reboot and test.

Reading this post:

…Makes me wonder about the xorg-server. It may be worthwhile for you to consider switching from the HWE (HardWare Enabled) xorg-server that comes with Ultimate to the standard xorg-server.

Thanks. I will try your suggestions. I do wonder what advantages I may lose by switching to the standard xorg-server.

Unless you are doing heavy video streaming and High GPU gaming,
-chuckle-Probably very little…