Mouse scroll wheel not functioning

I just installed Zorin os 15.3 and the scroll wheel never worked. It has no problem on another computer so I know the device isn’t the problem.
I used the application to test the device in the settings, it recognize the click from a middle button, but nowhere else than there, and never the scrolling.

Can someone help me? to be honest I’m a real newbie and have tried several tutorials unsuccessfully and most questions I found in forums are about the speed of the scrolling, not the scrolling itself.


@lilao Hi and welcome to the forum.
Which version of Zorin do you have e.g. Core or Lite?
What type of mouse is it?

In the meantime you could have a look at this to see if anything there may help you:

i’ve the education version and a gaming mouse (pro-m5 from “spirit of gamer” if it can be useful…)
i’m reading your link right now!

I’m so very sorry, that mouse was a friend’s gift and i didn’t realize it’s only for windows… I feel so silly, i’m sorry. Thanks anyway!

Not sure any mouse is “only for windows” whilst maybe some of the gaming buttons may be defunct it should still perform standard mouse tricks under linux.
Have you plugged in another mouse and found that to work properly?