My Apps are Not Appearing in the Start Menu ZorinOS 16 Pro

I tried to enter Linux verbose mode by hitting esc during Linux startup as the note you posted suggested. I must have been too early because I got a grub> prompt. Since I did not want to edit the grub file, I typed exit. Then I began to receive 'Enter valid boot media and press enter' repeatedly. After killing the machine by holding the start button for 5 seconds I was able to boot normally. I spent nearly all day today trying everything in the Universe to get my desktop files to work. I managed to get everything to show up in the app menu (dash?) and with their proper icons, but they still do not launch the apps. MenuLibre no longer finds errors in the files (although it complains about TexDocTK). I absolutely hate to give up. I need them to work.

UPDATE Sept 14, 2021
SUCCESS! SUCCESS! SUCCESS!
Problem 1: I needed to put X- in front of the new category ie
Category=X-Other
This caused a parsing error that prevented installation.

Problem 2: I needed to give read permission to group and other for all of the files in the folder containing my python app. ie
-rwxr--r-- 1 root root 3916 Sep 4 18:03 password.py
After doing this, the apps could be launched from the app menu (dash?)

Part 3 of the solution: I used the app desktop-file-install to install the desktop files. I do not know if this step is necessary, but it was this app that told me what the parsing error was. MenuLib only told me that there was an unknown error.

Note that the desktop files worked without doing any of these things under Z15.3 (Ubuntu 18.04).

1 Like