My desktop stretches off my monitor but my resolution is correct


My resolution is set correctly and the display area lines up on the right, top and bottom but my desktop stretches to the left off my screen. I've attached an image of my start menu showing where it cuts off on the left. If I do a screen shot of my whole screen it looks normal.

I've had this issue for a few days. Changing the resolution and back again doesn't fix it. I have Zorin Core 16.2.

Does anyone have any ideas?


Did you use xrandr to set your resolution? Many GUI tools write to a configuration file that the system does not actually see...
This makes Xrandr the right tool for the job.

Is this an external monitor or internal notebook screen? (Checking cables)

You may need to post the output of

lshw -C video

to this thread.

Wow, that was quick!

This is what lshw -C video says:

description: VGA compatible controller
product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:27 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64) memory:c0000-dffff

I didn't use xrandr, I just right-clicked on the desktop and went to display settings.

This is what xrandr says:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
VGA-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 527mm x 296mm
1920x1080 60.00*+
1600x1200 60.00
1680x1050 59.95
1280x1024 75.02 60.02
1440x900 59.89
1280x960 60.00
1360x768 59.95
1280x800 59.81
1152x864 75.00
1024x768 75.03 70.07 60.00
832x624 74.55
800x600 72.19 75.00 60.32 56.25
640x480 75.00 72.81 59.94
720x400 70.08
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

hmmm... what about

uname -a

uname -a says:
Linux sunlight-HP-EliteDesk 5.15.0-60-generic #66~20.04.1-Ubuntu SMP Wed Jan 25 09:41:30 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

I forgot to say, I did a clean install today and it's still there. It's a desktop computer with one monitor.

And thank you so much for your help! I couldn't find anyone with this issue doing a general google. I didn't even know what search terms to try.

Everything looks right so far... Does your monitor have buttons on it for built in monitor settings?

Also, are you logging in on Wayland instead of Xorg?

1 Like

Yes it does. I'll fiddle with those. Thanks for the idea.

1 Like

I just reset the settings and it fixed it! Thanks very much for your help.

That makes me feel a bit silly. I'm fairly new to Linux and assumed it was my lack of understanding of the OS - not my lack of understanding of those little buttons! :smiley:


That's good since my next suggestion was going to be to turn it off and back on again.



I was going to suggest a sledgehammer, but I can see the problem is solved :stuck_out_tongue:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.