My usb got destroyed

So basically ive had this expensive usb stick, and been making bootable ios on it for a long time, and i tried to install zorin os with rufus on the usb to make it bootable right? so when i finished the usb disconnected, i tried pulling it and sticking it back in my computer, ive tried with other devices the usb cannot be resetted, ive tried disabling, uninstalling the usb, i even tried to factor reset the usb with the manufactors drivers still no hope. ive never had this issue until i tried installing zorin os core

Hi Lean,

Welcome to the forum. I believe your USB stick dying when you installed Zorin is purely coincidence. If you read very much at all on this forum there are many discussions about the limited number of cycles of writing and reading that USB sticks have. You said yourself that you have been using it for a long time. Rufus is a good program for installing IOs so I think your USB stick just got to the end of its life. Balena etcher on the other hand has been known to kill USB sticks. Please try again with a new USB stick. The price of them has come way down in the last couple of years.

3 Likes

There are times that USB can't be reformat using computer "after making it bootable." I'd experience it when I make puppy linux live. The Puppy linux didnt work, and my flash drive considered as corrupted by my laptop. But, I still got the flash drive recovered through reformatting using cellphone. Yes, using OTG.

I also experience that even with otg in cellphones, or simple inserting, my flash drive aren't detected "but" in disks utility in Zorin, it can be detected. So, I reformat it there.

There's a lot of ways to recover flash drive depends on its damage, unless it was really literally destroyed.

3 Likes

Why did it happen to zorin os and not the other OS, maybe there'a bug or glitch in the OS that destroyed the usb?