Network connection delay

Hi,
has anyone had this issue and possibly a solution?
After a computer start the network connection is delayed for a min of 30 secs to 60 seconds on ethernet (no wifi).
This happens whether I login or not. I have contacted the router hardware vendor to see what they know without success (they analysed the logs)
So far this happened with ZorinOS 16 (only after a year of using it) and 17. After a couple of OS reinstalls and driver updates (attempts) this is still an issue.

Any help would be appreciated.

Cheers!

What is the computer and network hardware?

Have you checked for any breakages in the cable/tried a different ethernet cable? Tried a different port on the router? Is the router close or far away from the computer? Is the ethernet port on the computer part of the motherboard? Sometimes driver updates are issued by motherboard manufacturers, but you've probably guessed already it wilk need Windows.

This article may help:

Lastly, have you disabled IPv6 in Network settings?

[Footnote: When I was an IT Contractor I met a very knowledgeable guy who never got round to lending me a book that explained the physics of networks being slow as copper takes 30 seconds to warm up.]

Hi guys, thanks for your replies. In answer:

  • Network cable has been replaced and tested (several)
  • MB is a GA X570S AORUS ELITE with onboard network (it used to work for a year after the first ZorinOS install)
  • NVME gen4 2TB ssd
  • changed port on the switch
  • router is 5m away
  • disabled ipv6

Thanks for the link of the ethernet cable categories.

So, it worked. Do You have a Dual-Boot System with Windows on it? If yes, works it on Windows?

No, never had dual boot; always just either or.
First worked on Windows 10, then it worked on ZorinOs 16 for a year, then stopped.

Cheers!

Okay, then I would see it like this:

  1. There is some kind of Driver Issue
  2. Your Network Card or Chip on the Board is maybe broke

Have you tried rebooting your router?
Just something to eliminate.

Thanks @Ponce-De-Leon and @zabadabadoo.

The thought occurred about the board being broken just never had that before; tried the driver install to no avail.
Have restarted the router multiple times since.

Cheers!

1 Like