New Install Failing

After several attempts install went through, computer booted loaded Zorin and got as far as a light blue screen then crashed. "Oh no!.......gone wrong"
New to Zorin what do I do next? How do I find the fault? Terminology is so different to Windows and indeed DOS, so this is a steep learning curve.
Not dual-boot machine.

This looks like a file corrupted during the installation.

Fixing it may take a bit of work... Let's try the following:
Try tapping the esc or tab key at boot to pull up the Grub Menu.
From there, you should see the options to boot Zorin or boot Zorin OS Recovery
Choose the recovery option. This should offer you the Recovery Menu.
Arrow key down to the option to enable networking and get that enabled, first. Back up to the recovery menu, arrow key down to drop to Prompt.
Hit enter
then run these commands. (It helps to take a picture of this screen with your cellphone or use this page on your open cell phone to ensure each command is typed in exactly):

sudo apt update && sudo apt upgrade

sudo dpkg --configure -a

sudo apt clean && sudo apt autoremove && sudo reboot

If the above does not work, try

sudo apt install --reinstall zorin-os-desktop

Thank you for that. I will try. The esc or tab option di nothing as the screen froze on th "Oh no!.." screen. I will try the rest later.

esc or tab are for EFI systems. If you are using EFI, you may need to tap the key like it is Mortal Kombat.
If using MBR (Legacy) then use the Left Shift Key, instead (you can even just hold the key down.)

The only way I can get off the screen is to turn the
computer off. I have tried a new iso and get different
problems. Tried as a virtual computer on a Widows 10 and 11 machine and it completely messed up the wifi settings. Once it installed and the message was all was correct and to restart. This then bought up a list of problems. I need to access a damaged linux disk to get files off. Normal recovery programs will not do this. Its not as if I'm a computer newbee only to Linux. I was a system engineer for 40 years and this is the first failure I have had with different OS. Some have been difficult but thus....

What computer Make and Model are you installing on? Perhaps there may be a clue in the hardware as to why your experience is so muddled.

Actually, I use DiskDigger for this - it works just as well as it does on Windows.

Also: The "Oh no! Something has gone wrong" notes a Gnome-Shell crash. I would actually try installing Zorin OS Lite - as that uses XFCE, not Gnome.

Thanks Aravisian for the recommendation of DiskDigger. I recovered 97% of files from the faulty drive. Excellent program. Well worth the about £12 for a licence as could only do 1 file at a time without it: I had around 2000 to rescue.

I am a bit of a scrooge and always used the free version. However... my copy does not limit it to one file at a time. You can select the file types to search for, a save directory for the recovered files - then let it run. Perhaps something has changed... I will look into the latest version.