Newer kernel versions for Zorin OS to improve AMD spport?

Hey guys,

I would like to ask why don't you provide newer version of kernel for Zorin? Many people including me use new desktop hardware with for example Ryzen 9. There are many improvments/support for AMD, Intel in newer version of kernel like 5.15. When i used to linux mint i hadn't any problems to install newer kernels from ubuntu ppa but in Zorin there are issue during installation. Don't you think it would be better to provide newer version of kernel? or might you add some patchset for kernel?
Thanks :slight_smile:

It is a catch-22.
For some, the newer kernel works best. For some, the older kernel works since newer kernels can have regressions.
You can install a later kernel or Liquorix Kernel, though.