No display on Intel N300

I've been trying to install on my new N300 based mini PC. However I have some serious issues: Z16 doesn't even start, Z17 will start but after booting in install/try mode the HDMI port stops and no signal is found on the screen. If I start Z17 in safe mode, I can get it to run in 800x600 and run the installer, but after the rebooting it will quickly flash some ACPI messages and then lose the display again.

I would really like to be able to use my 4K display and upgraded from an old i5 gen 6 in order to have the power to run 4K video but alas, no video at all is running.

Debian 12.5 doesn't run on the computer either, though Manjaro Linux 24 seems to run fine (though it lacks chrome and I haven't looked into what it will take to port my own video player to it that I have written mostly on a Zorin 16.3 laptop, Using Qt5 and LibMPV)

The machine is a Minisforum UN300 mini PC barebones.

I suspect the problem is the kernel version: you said Manjaro 24 is the only one that works, which uses the 6.9 kernel, while Zorin 17 uses the 6.5 and Debian 12.5 uses the even older 6.1

You could try installing a newer version following these steps:

  1. Boot the Z17 installer in safe mode
  2. Assuming the non-functional Z17 installation is still there, select the option to try Zorin instead of install (or select install if you deleted it, and then come back to this step)
  3. Now we will chroot into the non-functional system from the functional USB, by doing the following:
  • Run this command to see the available drives:
fdisk -l
  • It should display something like this:

  • The last few lines are what's important here. There should be one or more names under the "Devices" tab named "/dev/[NAME_OF_THE_DRIVE]". Look which one matches the size of the partition where you installed Zorin.

  • If on doubt, if you didn't keep debian nor manjaro and just kept Zorin alone, it should be the one with the biggest size. If not, you can boot Manjaro to check the size of the partition it takes, and if Manjaro and Zorin are the only ones installed, it should be the one that doesn't appear mounted from the file explorer. Another possible option is (from Manjaro, but I think it should also work from the Zorin 17 USB), run this command:

sudo update-grub

Which will not just update the configuration file, but also tell you what operating system is installed in each partition, like this:

  • Now, once we know what's the name of the drive, write it down somewhere to not forget it, because we will need it soon

Now we can start to chroot into the broken Zorin

  • First of all, connect to the internet (we will need it to download the kernel later)

  • Then, open the terminal and run this command (it creates a temporary folder in the session where we will attach the drive -or partition- where Zorin is installed):

mkdir /rescue
  • Now we will mount the drive/partition that we searched for before inside the terminal from the Zorin USB:
mount /dev/NAME_OF_YOUR_DRIVE /rescue
  • Now chroot into it:
chroot /rescue
  • To be able to use graphical apps so you can use the GUI version of the mainline kernel tool, run this command:
export DISPLAY=:0.0
  • Then, open a new terminal window and, without chroot, run this:
xhost +

Graphical apps should work now

  • Now, let's run this command so chroot can access the wifi connection from the host Zorin USB (run it in the same terminal window as before, as this should also run WITHOUT chroot):
sudo mount --bind /etc/resolv.conf /rescue/etc/resolv.conf
  • Now we go back to the terminal window where we had chroot (if you closed it or forgot which one was it, you can open a new terminal window and run "sudo chroot /rescue") and add the repository for the mainline kernel tool with this command:
sudo add-apt-repository ppa:cappelikan/ppa
  • Then we install with:
sudo apt update && sudo apt install mainline -y
  • Now we open it with:
sudo mainline-gtk

Since the kernel used by Manjaro 24 (the distro you said that worked) is the 6.9, I'd say select that one from the ones that appear on the list (6.9.2 seems to be the newest one for that version number, according to the mainline kernel's website, so go for that one)

Now reboot and see if Zorin works

2 Likes

Thank you so much. A few issues I ran into with this description. - I needed to bind /dev and /proc into chroot too in order to run mainline.
mainline-gtk won't install a new image, claiming Failed to open PTY: No such device.
mainline install 6.9.2 from the commandline errors out with Error getting authority: not such file or directory.

Thank you again. I finally managed to get mainline to install 6.9.2 from the command line. I had so switch from pkexec to sudo. Since I'm not entirely sure what pkexec do anyway (I assume it runs packages in privileged mode, since I could replace with sudo) and now my system boots in Zorin 17.1 with my new kernel... It has been a while since I needed to do something like that. Thanks for the guide.

Would be good with more distributions being available out of the box for new hardware... Even as an "optional" download/install version...

1 Like

If you believe Sorro's post is the solution, can you mark it using the :ballot_box_with_check: Solution tool. Thanks