No internet connection for every app except torrent

Hello everyone,
I've been using zorin os for few months. The computer says it's connected to the internet. But everything except qbittorrent says there is no internet connection. Qbit is working fine, it's downloading and seeding stuff but every other application says there is no internet connection.
Previously when I faced this problem, I used to just reinstall the os.
I think protonvpn is one causing it because I hadn't used it for a while and everything was just fine.
Right after using protonvpn this happened.
Same happened last time.

If you are So Sure, Then the Solution is much Easier,


I did this it's still not working

I notice that happen sometimes when u r running protonvpn and u shutdown ur pc without closing protonvpn.
what u will do is that:
editing /etc/resolv.conf file, by adding that line in it
nameserver (ip of ur dns):
ex: nameserver
that will return the conection to internet temporary , then u open protonvpn again, and everything will work good permanently(to ensure it is working permanently, u need to restart pc but if u did that don't forget to close protonvpn before restart, or just restart ur network by disconnect and connect instead of restart pc)

1 Like

Well I wrote those 4 lines to sysctl.conf
And saved it with ctrl+s.
Then I opened a new tab and ran 'sudo sysctl -p'
But it's still not working

1-open terminal and add the command:[if u have installed gedit text editor use it, if not use nano instead of gedit]
sudo gedit /etc/resolv.conf
2-u will append that line in it:
nameserver there is space between nameserver and ip,note u will replace that with ur primary dns, u can get it from connection info from icon of ur network).
3-after save , the connection will work good, but if restart the computer, u will get the same problem again
4-to solve it premently, open protonvpn again, that should solve the problem

Where do I get the address that is written after name server

u r chat now from another device?, go to ur device and go to icon of network and get the properties of it, in my zorin lite , i get it from r-click on the icon of network, and get connection information, and u will see primary dns(it is the getway , which u connect to ur net service provider company)

Yes I'm using my phone to chat.
I don't see a network icon

type that in terminal
route -n

I have to install net-tools
Any other way to get that address?

i haven't use gnome de? so i don't know where u get the connection info, what is the result of command i have sent (route -n)?,u r using wifi, or wired in ur zorin?

The result of cmd was command route not found you can install it wit sudo spt install net-tools
And I am using wifi not wired

ok, try that command netstat -rn if not working go to search in ur zorin application and search for wifi app like that shown in that page, and u can find dns or getway in it

or try that command in terminal:

Nmcli gives some result
Should I send a ss?

u get that in result?
DNS configuration:
servers: ip

Yes, and that's the address I should write after nameserver right?

yes, don't forget to make space bw nameserver and ip

And press ctrl + s to save?