No sound (on laptop)

Hi,

I'm experiencing problems with the sound on my laptop's speakers (AKG). I'm currently using live boot and I haven't installed Zorin yet. The sound on any other computer that I live boot Zorin on seems to work alright but not this one. The drivers I'm currently using for the speakers are:

Intel(R) Display Audio
Intel(R) Smart Sound Technology (Intel(R) SST)
And Realtek(R) Audio

Zorin detects these speakers as "sof-hda-dsp". Over-amplification and raising the system sound didn't do anything. So for now, I'm using a workaround with my external speaker (Sony SRS-HG1) via USB. However, that takes up a USB-A slot and I only have two.

Can somebody please help?

One of these suggestions is a lot more involved than the other two:

That's for headphones, not speakers. And plus the following command listed didn't help as it couldn't find the file:


This command was in a guide in the link above.
So I had to find the file itself. But which one? Or should I not mess with it just yet?

"I had similar problem on my Ubuntu 18.04 - sound stopped working on built-in speaker and audio jack. It was working only on USB headset."

If the ~/.pulse file is not present, you can ignore trying to remove it.
The purpose of removing it is to remove any User Custom Configuration files related to Pulseaudio.
You may not have pavucontrol installed, as you are on the Zorin Trial, not the installed desktop.

Soooo, is there any way to install that or do I have to install Zorin for the speakers to work?

sudo apt install pavucontrol

So I've done that, and it's showing 'unplugged' next to my input device (headphones stereo microphone). Is there any way to solve that?

You can change things on a Live USB session, but unless you have Persistence setup on the USB, those changes or additional software will not survive a boot.

I know that.

I found a Bug Report on an issue with Sof on Intel Comet Lake:

The above relates to the 5.11 kernel, just a couple versions below what we are on on Zorin OS.
What generation is your Intel Chip?

My processor is an Intel Core i5-10210U, so that makes it a tenth gen. Maybe that's the issue?

It may be:

Possible workaround, install kernel that precedes 5.11:

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Sorry, I ran that command, but the speakers are still not playing anything.

You would need to boot into that kernel - which you can only do if you have Persistence since you are Testing Zorin on uSB.:wink:

Bummer. And I'm guessing persistence means installing Zorin on USB?

Update your kernel to 5.15, should fix sound issues.

So I tried to run that command and restart my computer (I installed Zorin now) but I'm still experiencing the same error. Any more things to try?

My kernel is 5.15 and it still has the same issues. I checked using ~$ uname -r.

Please open a terminal and enter:

cat /proc/asound/cards

and post back results.

Screenshot from 2022-07-16 20-23-13