No sound (on laptop)

Did you tried that solution?

Restarting Ubuntu means it always resets the audio output device to "Built in audio" but I want the audio output to stay in "HDMI / DisplayPort" How do I resolve this issue?
Unfortunately this fix was only tested on Panasonic Toughbooks, so we cannot guarantee that it will work on any other computers.
Here on some models samsung.

galaxy book2 pro audio problem | here this link problem is solved

I tried following the link on this post and still the same thing.

My microphone is connected with port USB. You have a laptop ten propably you get some chip Realtek or another type microphone. Your laptop using SoC chip? I have the same problem on motherboard no sound on another pc. I using a single audio adapter dongle. That's is problem on Linux and companies they are greed and don't wrote drivers. I wondering what type chip you have then we know if exist some solutions.

I reading many forums propably you have alc298 the same chip what my motherboard on another pc.
It seems all you need to do is install the sof-firmware package and reboot.
Here on this link under is solution
drivers - Sound card not detected - Ubuntu 20.04 - sof-audio-pci - Ask Ubuntu but i don't know if working for you.

I tried the lower link and it still doesn't play sound, and now it's not detecting the microphone. On the bright side though, it's saying built in speakers instead of sof-hda-dsp.

No drivers this what i can sayed. The samsung galaxy laptops are diffrent with components. Propably for your version a laptop the drivers linux doesn't exist.

I think this really should be in the current kernel in use by Zorin OS at this time.
@Turtle11 , can you please try this tip found here:

And see if that helps?
If not, we may need to try elevating you to a higher kernel.

this is the speakers what @Turtle11 using.

Same issue. However, when I tried to do this, my thing was showing Realtek ALC298 and not ALC256.

Updating the kernel is very risky, I know from experience because I tried following a guide to update to kernel 5.15 and I encountered a black screen upon startup and I was forced to reinstall Zorin. But if you're saying this the only option left...

I've changed speakers recently.

And now Spotify doesn't play sound.

Yes. The changes in grub - did you back the old settings grub before link what you uesed?

Er, no.

Then it will be good idea back some settings if not working when you tried something . I reading when you tried installing Realtek in linux the firmware don't have a candidate. Your screens upper.

What's that supposed to mean?

That could be means.
Well, both drivers in that link have the letters "rc" in them, which to me means release candidate, which means alpha or beta, which means unfinished and buggy.

Well, let's just focus on updating the kernel first like @Aravisian said.

@Aravisian, sorry to bother you or ask, but do you know what the latest kernel version is and how to update to it safely?

If you had a black screen when upping the kernel before, I think that your best bet is not to focus on the absolute latest kernel, but only on the "safely" part.
Bear in mind that if the kernel does not work, you need only to tap the esc key at boot, pull up the Grub Menu, select Advanced Options for Zorin and then boot into the Previous Working Kernel in order to correct the issue. Once logged in on your desktop, you can remove the offending kernel and solve the issue that the later kernel caused.

Let's try the tuxinvader kernel. I have used the Tuxinvader kernel a lot... But he is currently on the 5.19 kernel which I have not yet tested on Zorin OS.
Hold your breath

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install -y linux-generic-5.19

Reboot and test...
In terminal run

uname -a

to ensure you are using the 5.19 kernel, then check your sound devices...

Invalid signature...

It's a good thing you taught me how to downgrade...

I'm not sure there is a lot more we can do...