No sound (on laptop)

Mmm Kay, maybe I should disable secure boot in the BIOS and then try again.

Before I moved to Linux, Windows required me to enable it and leave it on for 11. I probably forgot about it when I changed OS.

1 Like

That is one of the requirements Windows 11 sets...

Disabled secure boot...

...and installed kernel 5.19...

...but still the same error.

Now we may be out of ideas...

Can you please post the terminal output of

sudo lshw -C multimedia

I'm pretty sure I switched from pulseaudio to... what was it called again? Pipewire?

Hmmm sof-audio-pci-intel-cnl...
Let's try falling back to the intel driver and not using SOF.
Can you please run:

sudo nano /etc/default/grub

Arrow key down to the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add the parameter snd_hda_intel.dmic_detect=0
So that it looks just like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"
tap ctrl+x to exit, then the y key to say yes to save. Then the enter key to save as current configuration.
The terminal will revert to normal.
Now you must run

sudo update-grub

for the above changes to take effect.
Reboot and test sound...

Is it OK if I use gedit instead of nano? I find it easier to use gedit than nano.

Certainly, no problem. Use whatever you prefer.:slight_smile:

Same thing. Probably what happened last time I tried this in post 54.

Oh yes, I know immediately because I set my OS to play the Zorin boot chime on login.

I would not rely on this definitively. Sound can work just fine while the login chime does not...

Oh snap... I just reverted back on the grub file.

GitHub - thesofproject/sof-bin: Firmware and topology binaries @Aravisian can study that if this anything help?

1 Like

It is worth trying...

Uhh... I'm not it says anything about properly installing.

It gives the install instructions:

cd v1.7.x
rsync -a sof*v1.7   /lib/firmware/intel/
ln -s sof-v1.7      /lib/firmware/intel/sof
ln -s sof-tplg-v1.7 /lib/firmware/intel/sof-tplg
rsync tools-v1.7/*  /usr/local/bin

Yeah, except the release file shown in GitHub is now v2.2 or something and I'm not sure if it's the same installation.
--Oh wait there is still a v1.7 file here, I didn't look properly. Whoops.

Which version should I use?

I do not know... Probably the later more recent version. But I am not well familiar with the inner workings of what makes them different.
Trying it is a shot in the dark... You have already begun to think there is no hope. So other than spending some time trying out different possibilities, you have little to lose.

Remember I'm not as persistent as you guys, but I'm trying.

I might need a little bit of help here...

Actually don't worry, I've figured it out. So I followed these instructions, now do I have to restart?