No sound (on laptop)

Trying to find a Linux version for sound drivers (as mentioned in first post). It looks like there are no native Linux drivers for those (or these?).

1 Like

So what's going on here? I'm reading it and I'm a bit confused.

Here under some ppl found a solution.

That's interesting, I don't have an option in modprobe.d that says options snd-intel-dspcfg at all.

What is your model laptop maybe i can find more info with research your problem.

Samsung 950XCJ/951XCJ/950XCR (Galaxy Book Ion) as far as what I saw on Neofetch.

Did you tried that solution?

Restarting Ubuntu means it always resets the audio output device to "Built in audio" but I want the audio output to stay in "HDMI / DisplayPort" How do I resolve this issue?
Unfortunately this fix was only tested on Panasonic Toughbooks, so we cannot guarantee that it will work on any other computers.
Here on some models samsung.

galaxy book2 pro audio problem | here this link problem is solved

I tried following the link on this post and still the same thing.

My microphone is connected with port USB. You have a laptop ten propably you get some chip Realtek or another type microphone. Your laptop using SoC chip? I have the same problem on motherboard no sound on another pc. I using a single audio adapter dongle. That's is problem on Linux and companies they are greed and don't wrote drivers. I wondering what type chip you have then we know if exist some solutions.

I reading many forums propably you have alc298 the same chip what my motherboard on another pc.
It seems all you need to do is install the sof-firmware package and reboot.
Here on this link under is solution
drivers - Sound card not detected - Ubuntu 20.04 - sof-audio-pci - Ask Ubuntu but i don't know if working for you.

I tried the lower link and it still doesn't play sound, and now it's not detecting the microphone. On the bright side though, it's saying built in speakers instead of sof-hda-dsp.

No drivers this what i can sayed. The samsung galaxy laptops are diffrent with components. Propably for your version a laptop the drivers linux doesn't exist.

I think this really should be in the current kernel in use by Zorin OS at this time.
@Turtle11 , can you please try this tip found here:

And see if that helps?
If not, we may need to try elevating you to a higher kernel.

this is the speakers what @Turtle11 using.

Same issue. However, when I tried to do this, my thing was showing Realtek ALC298 and not ALC256.

Updating the kernel is very risky, I know from experience because I tried following a guide to update to kernel 5.15 and I encountered a black screen upon startup and I was forced to reinstall Zorin. But if you're saying this the only option left...

I've changed speakers recently.

And now Spotify doesn't play sound.

Yes. The changes in grub - did you back the old settings grub before link what you uesed?