No sound (on laptop)

Er, no.

Then it will be good idea back some settings if not working when you tried something . I reading when you tried installing Realtek in linux the firmware don't have a candidate. Your screens upper.

What's that supposed to mean?

That could be means.
Well, both drivers in that link have the letters "rc" in them, which to me means release candidate, which means alpha or beta, which means unfinished and buggy.

Well, let's just focus on updating the kernel first like @Aravisian said.

@Aravisian, sorry to bother you or ask, but do you know what the latest kernel version is and how to update to it safely?

If you had a black screen when upping the kernel before, I think that your best bet is not to focus on the absolute latest kernel, but only on the "safely" part.
Bear in mind that if the kernel does not work, you need only to tap the esc key at boot, pull up the Grub Menu, select Advanced Options for Zorin and then boot into the Previous Working Kernel in order to correct the issue. Once logged in on your desktop, you can remove the offending kernel and solve the issue that the later kernel caused.

Let's try the tuxinvader kernel. I have used the Tuxinvader kernel a lot... But he is currently on the 5.19 kernel which I have not yet tested on Zorin OS.
Hold your breath

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install -y linux-generic-5.19

Reboot and test...
In terminal run

uname -a

to ensure you are using the 5.19 kernel, then check your sound devices...

Invalid signature...

It's a good thing you taught me how to downgrade...

I'm not sure there is a lot more we can do...

It appears that you have Secure Boot enabled in your BIOS /EFI settings...

Will that affect my OS experience if I turn it off?


If you are dual booting with Windows, you may prefer to leave Secure Boot enabled. If you are not booting Windows, it should be off.
The Secure Boot program is For Windows.

Mmm Kay, maybe I should disable secure boot in the BIOS and then try again.

Before I moved to Linux, Windows required me to enable it and leave it on for 11. I probably forgot about it when I changed OS.

1 Like

That is one of the requirements Windows 11 sets...

Disabled secure boot...

...and installed kernel 5.19...

...but still the same error.

Now we may be out of ideas...

Can you please post the terminal output of

sudo lshw -C multimedia

I'm pretty sure I switched from pulseaudio to... what was it called again? Pipewire?

Hmmm sof-audio-pci-intel-cnl...
Let's try falling back to the intel driver and not using SOF.
Can you please run:

sudo nano /etc/default/grub

Arrow key down to the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add the parameter snd_hda_intel.dmic_detect=0
So that it looks just like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"
tap ctrl+x to exit, then the y key to say yes to save. Then the enter key to save as current configuration.
The terminal will revert to normal.
Now you must run

sudo update-grub

for the above changes to take effect.
Reboot and test sound...

Is it OK if I use gedit instead of nano? I find it easier to use gedit than nano.

Certainly, no problem. Use whatever you prefer.:slight_smile:

Same thing. Probably what happened last time I tried this in post 54.

Oh yes, I know immediately because I set my OS to play the Zorin boot chime on login.

I would not rely on this definitively. Sound can work just fine while the login chime does not...