No sound (on laptop)

Oh snap... I just reverted back on the grub file.

GitHub - thesofproject/sof-bin: Firmware and topology binaries @Aravisian can study that if this anything help?

1 Like

It is worth trying...

Uhh... I'm not it says anything about properly installing.

It gives the install instructions:

cd v1.7.x
rsync -a sof*v1.7   /lib/firmware/intel/
ln -s sof-v1.7      /lib/firmware/intel/sof
ln -s sof-tplg-v1.7 /lib/firmware/intel/sof-tplg
rsync tools-v1.7/*  /usr/local/bin

Yeah, except the release file shown in GitHub is now v2.2 or something and I'm not sure if it's the same installation.
--Oh wait there is still a v1.7 file here, I didn't look properly. Whoops.

Which version should I use?

I do not know... Probably the later more recent version. But I am not well familiar with the inner workings of what makes them different.
Trying it is a shot in the dark... You have already begun to think there is no hope. So other than spending some time trying out different possibilities, you have little to lose.

Remember I'm not as persistent as you guys, but I'm trying.

I might need a little bit of help here...

Actually don't worry, I've figured it out. So I followed these instructions, now do I have to restart?

Sorry, got called away to work.
I imagine you have restarted, by now...

Yes, and still the same thing unfortunately. But we can't lose hope yet.

Would the TPM have anything to do with the audio system by any chance?

I believe opensuse will working without problem.
You can trying in live linux opensuse if you get sound and microphone working. I remember i don't have problems with drivers my gpu working out from the box but in ubuntu Zorin need all doing manually. You can trying installing and maybe there finding some drivers what will be working. It is possible installing any type package on linux distribution.
So this is possible another distribution have some drivers and ubuntu don't have drivers for your hardware?

I'm not sure if I want to switch distros...

I think what I meant by TPM is Trusted Platform Module.

And last time I tried to do that, there is no option to run a live boot.

It really shouldn't...

TPM is an oddball device by any measure.
It is multi-functional, but one of the purposes that it serves is operating as a backdoor allowing Microsoft remote access to your machine. Microsoft says that this is a security feature enabling MS technicians the ability to access and remotely repair the machine.

Then why was it needed for 11?

And is there anything else we can do?
Not that I'm giving up or anything - I been working to resolve this issue with the community for over 2 months now, so I can't give up now. Even though I felt like it before.

With the introduction of Windows 11, Microsoft implemented far more strict requirements on systems. This included requirements that they say are for Security (Like TPM ), but also requirements that they say are for performance.

TPM can help with security. But as a hardware module, it is problematic. For a Windows user, they may get some good out of having it. But as a backdoor, it is accessible, and that could be viewed as a security flaw. Any backdoor accessible by a remote party would raise eyebrows.
Some users preferred to keep TPM disabled, preventing Microsoft (or any malicious actor) from being able to use it to remote access their machine for whatever purpose.
With Windows 11, Microsoft said, "you are not allowed to shut us out, anymore."

Have you already added options snd-hda-intel model=asus-zenbook
to /etc/modprobe.d/alsa-base.conf?

If I am misremembering and you are not using Asus Zenbook, please correct that. This thread has gotten quite long to scroll through.

Samsung 950XCJ, and not ASUS Zenbook. That's for the other user. Would you mind if I link that post on the other topic?

1 Like