No user interface after changing mount option for partion

i have played in mount option for filesystem partition,mark and unmarked in that settings, why i did that stupid things ? because i was getting auto open to all partitions in file manger when i open pc,so i tried stupid things.


i lost the gui interface and i get that message

i tried that command to get gui :mount - o remount rw /
I get gui but without internet, and every time i restart pc i get that result and to get gui must type that command.
and that the content of the fstab file:
image

Can you provide more details?
Did you modify fstab file?


I have changed settings as in the picture for the filesystem.

I can't login to graphical interface, i get that problem

I cannot read the second image information as the image is too blurry. Without really knowing what you were mounting and why you changed the mountpoints for the file system, I am left guessing.
You can use the id command in the above terminal window to identify your drives /devices.
Then the mount command to mount your primary drive... Replace EXAMPLEDEV with what you got from using id above:

sudo mount -o uid=1000,gid=1000 /dev/EXAMPLEDEV

i get that:
can't find in etc/fstab

It looks like Root is not mounted or accessible.
What exactly did you do?

1 Like

i have played in mount option for filesystem partition,mark and unmarked in that settings, why i did that stupid things ? because i was getting auto open to all partitions in file manger when i open pc,so i tried stupid things.


i lost the gui interface and i get that message

i tried that command to get gui :mount - o remount rw /
I get gui but without internet, and every time i restart pc i get that result and to get gui must type that command
and that the content of the fstab:

/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

/ was on /dev/sda4 during installation

/swapfile none swap sw 0 0

eid, boot from the live usb media, select try zorin, and then click on gnome disks.
from there reput the mount options to the default.

I have done that but didn't solve the problem, I think when I changing mount option from gnome disks app in the first time, that effect on the settings in fstab file.

when I played and make changed by gnome disks app, that effect in fstab file as shown below:
image
I fixed that by: type that command first to enter gui interface
sudo mount -oremount ,rw /
then I edit fstab file:by gedit app
sudo gedit /etc/fstab
then i added the highlight line in pic(mount my filesystem(/dev/sda4 on / as the line above it reminder me the deafult settings that i changed)
image