No WiFi Adapter Found - Lenovo Laptop

Doesn't work, i have the same error.

Did you download and extract the files to Documents?
Or are they in Downloads?

sudo cp ~/Downloads/git/rtw89/rtw8852a_fw.bin /lib/firmware/rtw89

You can see how that is working...:
sudo for Privileges, cp to copy, path/with/the/file path/that/is/the/destination/for/file

The folder rtw89 has path /home/zartilas

update: i Transferred the folder to Documents and i running the command [sudo cp ~/Downloads/rtw89/rtw8852a_fw.bin /lib/firmware/rtw89] again. I haven't any error.

Follow the proper path to the file on your computer.

Ok, i ran this commands :

sudo cp ~/Documents/rtw89/rtw8852a_fw.bin /lib/firmware/rtw89
sudo modprobe -r rtw89pci
sudo modprobe rtw89pci

modprobe: ERROR: could not insert 'rtw89pci': Operation not permitted

and i have error only in the last.

Ok, I need to leave for an hour or so- hopefully @Michel is still around to continue assistance if you are in a hurry...

2 Likes

@zartilas,

The solution is to disable secure boot. I see your running Zorin in dual boot so i assume your using Windows as well.

Firstly check if SecureBoot is enabled on Zorin OS.

Install mokutil sudo apt-get install mokutil

and check the status of SecureBoot mokutil --sb-state

In case it is enabled run command sudo mokutil --disable-validation

OR

Turn off secure boot in your bios.

3 Likes

(Facepalm)

I didn't even think of it...

2 Likes

Oops.
Same here...

Michel +1 vs Moderators 0

1 Like

That worked. Thank you.

3 Likes