NVIDIA driver not working since kernel update

When installing xanmod kernel the nvidia drivers stop working, after removing them to reinstall them, they are not installed, so... What can I do?

Perhaps wait for the nvidia driver to get updated to keep up with the custom kernel.

EDIT: and now you can't install the nvidia driver after removing the custom kernel?

Can you Please Explain, How you came to the Conclusion that the Drivers are not working. Did you Change Anything? Also, which method you used if you tried reinstalling the drivers? Is the Desktop gone or the System working slow?

Nvidia Drivers often use DKMS (Dynamic Kernel Module Support) in order to enable the drivers to "roll with" elevating the kernel.

Most likely, DKMS cannot locate the correct module. What this suggests to me is that when you installed Xanmod kernel, you may have installed only the headers and not the complete modules package.
Can you please outline what steps you took to install the Xanmod kernel? We may need to install xanmod-modules.

1 Like

I don't think it's a kernel problem, I was investigating and it's something that ubuntu 20.4 has, since pop!_os that is based on 22.04 didn't have this type of problem

No, after installing a different kernel, (because I tried with xanmod 5.15) this problem arises, and since I use a laptop, I am currently using integrated graphics

I did as suggest this page

Which edition did you choose? The standard:

linux-xanmod

Or the LTS or the Edge?

You did notice the warning at the top for lack of Secure Boot support, right? Are you using Secure Boot?

No, and well I'm using the edge version, and I've never had these problems, only in this distribution, well... I guess I'll have to use something else, and well grub doesn't work for me so I'm trying to solve it, I'll change of kernel to see if this is solved

The Linux kernel is a bundle of hardware drivers. A large bundle.
It may be necessary sometimes for a user to elevate to a newer kernel if they are on very new hardware that needs support that has only been recently added to the kernel. And the Edge Kernel is a very latest kernel, indeed. Including that it is non-LTS and contains regressions.

That aside, it is safest for users to adhere to the vetted kernel provided by their distribution.

You mention Grub not working - that is pretty serious...
And I am (only vaguely) aware that you have been facing other difficulties.

I wonder if stepping back for a moment and covering what your goal is might be helpful in developing a plan to tweak your system to perform and be as desired, but without a lot of these hurdles.

1 Like

thanks, although for some reason whenever I install zorin os grub never never works, the only time it worked was when I had windows installed (I mean dualboot)

Can you please clarify what you mean by this statement?
Are you using a different method than Grub?
Or... do you mean that upon boot, the Grub Menu is not shown?

The Grub Menu generally only appears if the user tells it to or if the system is dual booting, as the menu allows the user to select which OS to boot up.

You stated that you followed Pop OS guide. Pop OS as in that article is based on Ubuntu 22.04, Zorin 16 is based on 20.04.x.

I noticed that too. But the commands listed do not specify POP_OS nor do they point toward the Jammy repos.
They should have worked, really...

1 Like