NVIDIA Driver problems

Hello everyone,

I've recently installed Zorin OS Pro with the "modern NVIDIA" setting at the installation and came to several issues regarding my NVIDIA graphic card. After my first installation, I opened up the NVIDIA X System Application to see if everything is working well, but all I got was a blank window without anything. After i kinda manually reinstalled the nvidia driver from "Additional Drivers" and restarted my pc (with secure boot), the application showed the "PRIME" settings, but every application I would open would last a couple seconds longer to open as usual. Everything really lagged and did not work as normal as it did before.
I've now tried to reinstall ZorinOS but came with the same issue. I will be sticking with the installation with the NVIDIA modern settings without manually reinstalling the drivers afterwards. The NVIDIA X System will just remain blank after all but I have to deal with it I guess. I am just concerned if the os really uses my nvidia graphic card when it's needed or just never recognizes it. Any suggestions?

1 Like

I guess you have a dual gpu ? Intel / nvidia combo ?

I also have nvidia. What worked for me was using an older driver.

In the software center click the 3 dashes on the upper right - chose Software & Updates. Then click Additional Drivers tab. Chose an older driver. You may have to do this with a couple different ones until you find one that works for you.

2 Likes

I have had this problem and it was due to installing the wrong driver. I was thinking the latest tested driver would would work , but I was wrong.

Is this a dual boot ?

1 Like

I tink birds of a feather...

I have that problem and repaired when download driverem from original website NVIDIA and installing them with instruction on that website.

I use this driver with dual and works fine.

nvv

1 Like

Yes. Intel/Nvidia

What Nvidia card model are you using and which driver did you select from Additional Drivers? Did you try the 510 Proprietary and the Nouveau open source?

If none of those are working, please open a terminal and run

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade