Nvidia Problem some games Freezing

Have you tested your RAM or vRAM?

Can you tell me how on linux? Is there a tool? in my bios I don't remeber if there is a test feature.

Alright I see memtester I check that at home.

Hi so I readed manual and after memtest echo shows 137 which is out of memory. Here are screenshots:

memtest
neofetch

In guide they said to use ram size installed on pc. So I did it. Is it hardware or can I do something in linux itself?

That tested your RAM and while not ideal - it still looks usable.

Please see this guide for testing your Graphics Card and vRAM.

Okay so I tested using glmark & Unigine Superposition. Here are the results:

UniEngine 1080 medium:

UniEngine 1080 High:

UniEngine 1080 Extreme:

Could you look at the results? I think they are ok but I would like to know your thought on this.

Sorry, I had somehow not seen the post you made above at the time you made it.
The fps looks a little on the low side to me, but I do not see anything in that test that actively tests the VRAM.
Everything else looks quite good.

Ok, no problem. If everything it's fine I don't know whats the issue, why os freezes. Tell me is your Zorin OS uses so much ram?

Is it normal?

No, it doesn't... But I use Zorin OS Lite, not Core.
So that may be part of the difference:

Nvidia GeForce RTX 3060

You think reinstalling the system will help?

It is entirely possible that a fresh, clean reinstall can alleviate the problem. While we try to troubleshoot as best we can, it is noteworthy how often a reinstallation does wonders.
Just keep in mind, it may not fix the problem, too.

Thank you for your support. I will backup my data and try that.

Hi,
I managed to fix the problem without reinstall. It was swapfile. I had 2GB swapfile. I don't know how exactly happend but I created second file with 8GB and now no hangs. Thanks again all. This topic can be closed now.

1 Like

@337harvey recently posted about an application called "NoHang":

Might be worth looking into, as well.

Alternative: Oibaf testing repo:

sudo add-apt-repository ppa:oibaf/test

sudo apt update && sudo apt install nohang

sudo systemctl enable --now nohang-desktop.service

1 Like