NVIDIA RTX 970 not working

I switched from Windows to Zorin but my NVIDIA driver isn't working properly. The screen is flickering, the screen is at 1024x768 when it must be 1920x1080 and the second screen isn't showing. And the worst part is that Additional Drivers can't install other drivers. How can i fix this?


Please open a terminal with ctrl+alt+t
Enter in and run:

sudo apt update && sudo apt upgrade && sudo ubuntu-drivers install

Once all is complete, please reboot, then check additional drivers.

1 Like

I typed the command in and restarted, and now i'm in Additional Drivers, what driver do i need to choose?

I use the 510 Proprietary Tested; it works well for me. But you have a choice- use any of them that work well. Nouveau (open Source) or Proprietary. I do recommend Avoiding the 47- Proprietary Tested, though. It has had a lot of problems.

I changed from 470 to 510 but i don't see any differences. Is there an other way to fix it?

Are you on Desktop PC or Notebook computer? Is this a plugged in monitor or built in?

Its a desktop PC with 2 monitors

Same as me. I had some trouble on mine on the Nvidia Card ports - I plugged into the HDMI - Nvidia wanted me to use the Display Port instead. I used adapters and plugged both in Display Port and everything worked properly.

Can you please open a terminal and run


and paste the output here?

I got

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00*

sudo nano /etc/default/grub

What is the output of line: GRUB_CMDLINE_LINUX_DEFAULT=

Are you booting in Safe Graphics?


Did you Reboot after switching Drivers? If So:
Let's try setting the mode:
If connected by HDMI:

xrandr --addmode HDMI0 1920x1080_60.00


xrandr --addmode HDMI1 1920x1080_60.00

If by Display Port:

xrandr --addmode DP0 1920x1080_60.00
xrandr --addmode DP1 1920x1080_60.00

I restarted the system after changing Drivers.
And the commands don't work, i get this result:

xrandr: Failed to get size of gamma for output default
xrandr: cannot find output "HDMI1"

This can depend on which port you are plugged into. Some cards have up to four.

I tried HDMI0 to 4 and DP0 to 4 but still nothing.
I went also to settings to About and i saw that in Graphics it said "llvmpipe (LLVM 12.0.0, 256 bits)" could this be the problem?

Hmmm... still looks like it is not using your Nvidia driver...
if you tap alt+F2 and enter in nvidia-settings, does it offer you the Nvidia XSettings Window?

Yes, but i see nothing in there

Can you please expand on this? Nothing in there in regards to resolution? Or nothing at all?

I mean that the app is empty, that's what i see:
Screenshot from 2022-03-23 19-57-31

Definitely looks like Nvidia is not installed.
Output of:

ubuntu-drivers devices