Zorin Forum

NVIDIA RTX 970 not working

Yes, but i see nothing in there

Can you please expand on this? Nothing in there in regards to resolution? Or nothing at all?

I mean that the app is empty, that's what i see:
Screenshot from 2022-03-23 19-57-31

Definitely looks like Nvidia is not installed.
Output of:

ubuntu-drivers devices

I typed this command to terminal and i got:

vendor   : NVIDIA Corporation
model    : GM204 [GeForce GTX 970]
driver   : nvidia-driver-418-server - distro non-free
driver   : nvidia-driver-510-server - distro non-free
driver   : nvidia-driver-450-server - distro non-free
driver   : nvidia-driver-390 - distro non-free
driver   : nvidia-driver-470-server - distro non-free
driver   : nvidia-driver-470 - distro non-free recommended
driver   : nvidia-driver-510 - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

What does this yield:

sudo apt install -f nvidia-driver-470

It's completed, do i need to restart my PC?

Yep, let's test...

Hi, sorry that you needed to wait long.
I restarted my system and i still have these issues. And on settings it says still that my graphics are "llvmpipe (LLVM 12.0.0, 256 bits)"

In your BIOS EFI settings, Secure Boot must be disabled.
Please check that it is and disable it if it was not. Then reinstall the Nvidia-Drivers and test.

I powered off my PC but i forgot to press the F2 key to enter BIOS, but when i booted up to Zorin i saw that the screen was changed into 1920x1080, but the screen is still flickering and the second screen isn't showing. Maybe i know why my screen is flickering because my monitor is a 120HRz monitor and maybe the system is at 60HRz?

It's certainly possible. Why not change your refresh rate and test it out?

but how? i still can't change it on settings.

If xrandr isn't working...

xrandr --output HDMI1 --rate 120

You can configure the .xml file ~/.config/monitors.xml
Open it with Text Editor.
Look for

      <width>1920</width>
      <height>1080</height>
      <rate>60</rate>

Change rate to 120
Save and exit, log out and in or reboot to test...

Ummm yea... there's a problem


I am not sure if the HDMI1 is the accurate ID for you to use.

If using Terminal, remember that you are specifying the path to the file in your Home Directory with tilde (~) and you must specify an editor tool:

sudo nano ~/.config/monitors.xml

Edit...
On mine, it also showed that as creating a New File. What?

Same on my terminal

Would it be a good idea if i would install the drivers from there official website?

Please see this post here, specifically the part about the 5.8 kernel:

Yes, you can install the drivers directly from Nvidia. The downside of doing this, is that you would have to reinstall the drivers each and every time the kernel upgrades.
Using DKMS with the Zorin Supplied driver, helps prevent that problem.
I wonder if using the 5.8 LTS kernel may work better with the DKMS driver may work out better.

Hey Aravisian, sorry that you didn't get any messages back.
My problem has been resolved, it turned out that in my UEFI settings i didn't turned off Secure Boot

1 Like