One cpu core idles at 100%

I was trying out zorin os 16 core but noticed immediately that one of my cores was at 100% and didnt come down even when i closed every running app. system monitor (app and top on terminal) doesnt show whats taking up so much resources. what can i do? cpu is intel's i5-7300U

Install Stacer. Click resources icon in app. Then click CPU tab filter, then you should see what's eating 100%. It's probably Gnome Shell if I had to guess. Or, you could have a process that's bugging out.

I remember a few times the hidpi daemon bugged out, causing 100% CPU usage until they ended the process.


I tried stacer. It didnt tell what process is taking up a lot of resources but shows that one core is running 100% all the time. Stacer itself took up a massive chunk of cpu usage all together making the system run overall at least 85%. Other distros ive tried havent had this problem, only zorin and elementary.

Normal. But if you stay on it, you'll see Stacers usage go down as it normalizes. A resource monitor uses CPU to function, so naturally that causes an increase.

It's not normal for a resource monitor to not show you what is using so much CPU. Your OS might be suffering a memory leak too.

What apps have you installed other then Stacer? Have you had this issue since the very beginning? Or did this issue start up over time after installing apps?

Also, how much RAM you got? If you got 4GB or less, your OS might be SWAP filing like crazy to the hard drive. I'm going to bed, others can help you if no solution.


Nothing else yet. This is occuring on a fresh install of the os. I have 8gb ram

Maybe Zorin and elementary OS which both are build upon Ubuntu 20.04 uses the same kernel.

Maybe. I guess i'll just have to install ubuntu even though i despise the look and the difficulty of installing gnome shell extensions. I'll try again sometime later, maybe a new update fixes things in zorin

You could try installing a newer kernel on Zorin if you wish to test it.

Are you using a 4k monitor?

Would you mind posting inxi -t cm? Iā€™m still curious.

Marked Solution. 322

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.