Pdf opens with imagemagic

recently when i open a pdf from filemanager(gnome default) the pdf opens with imagemagic.
When i try setting document viewer as default by right click-->properties->open with-->selecting document viewer as default it does nothing ie: image magic still remains the default app
additionally i tried following this tutorial

but cant find .config/mimeapps.list folder

additional info:
zorin os 16.2 core gnome

The error started after i shared a folder with my mobile phone via zorin connect and tried opening a pdf in the shared folder, which opened with imagemagic, now forcing all other pdf in pc's storage to open with imagemagic as well

There should be two mimeapps.list files (it is a file, not a folder).
One in ~/.config
The other in /usr/share/applications

While you are checking /usr/share/applications, open the document viewer (org.gnome.Evince.desktop) .desktop file and check the MimeType line.
It should look like this:

MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;application/x-xzpdf;application/x-ext-pdf;application/postscript;application/x-bzpostscript;application/x-gzpostscript;image/x-eps;image/x-bzeps;image/x-gzeps;application/x-ext-ps;application/x-ext-eps;application/illustrator;application/x-dvi;application/x-bzdvi;application/x-gzdvi;application/x-ext-dvi;image/vnd.djvu+multipage;application/x-ext-djv;application/x-ext-djvu;image/tiff;application/x-cbr;application/x-cbz;application/x-cb7;application/x-cbt;application/x-ext-cbr;application/x-ext-cbz;application/x-ext-cb7;application/x-ext-cbt;application/vnd.comicbook+zip;application/vnd.comicbook-rar;application/oxps;application/vnd.ms-xpsdocument;

I can only see mimeinfo.cache here

but searching in filemanager i was able to locate it in .config
thank you very much