Photos not transferring

I recently tried to update a profile picture at another site that I participate at. I followed the download procedure at that site, saw the photo I wanted to share displayed, but when I look at the profile there, all that shows is a 'blank' square.

I checked the Privacy & Security Settings but don't see anything about limiting downloads. Any thoughts? Thanks for all assistance :grinning:

1 Like

Now that I made some practice with Firefox developers' console I can do many interesting things, including finding pictures and multimedia sources that I want to download when maybe the download button is only available after a registration, authentication or simply denied by the publisher or owner of the website. Once I understood it the first time I simply applied that discovery to my further needs. Can you send the link here so I check that?

Workaround: set the picture you want to full-screen, take a screenshot and use that screenshot for what you need it. If the picture doesn't have the right aspect ratio just edit it and cut the picture as you wish.

2 Likes

Thanks Luca for sharing those hints! Perhaps I didn't make it clear - the difficulty I have had is with copying a photo - on my computer (usb stick) TO a web site where I want to have my photo visible. Hmmm could the 'privacy' issue have to do with working off of a usb sitck? I'll try putting the photo onto my desktop and see if that works.

I also like the idea of using a screenshot as a 'transfer' media. You have given me some methods I can try. Will report back as I give those a go.

Thanks again :smiley:

1 Like

Curses! Luca I tried both methods and sadly neither worked :cry:. I can't help but wonder if there isn't a privacy setting that is causing this failure to transfer?

1 Like

I looked at the (Zorin) settings unlocking the Location button in Privacy. Didn't change help, still can't get the photo to upload to the site. I also unlocked the button in the Sharing setting (restarted computer) and no joy there.

This is getting to be a thing now - really wondering why this isn't working.

1 Like

I do not see how any privacy settings on Zorin OS would have the effect that you describe.
This is undoubtedly related to that page or possibly browser; not to any OS that you are using.

3 Likes

Can you actually open the photo on your computer at all?

It may be worth trying to copy the file from the USB to the computer, and then upload it.

How are you uploading the file to that other website, drag and drop? Try to use the file browser that prompts when you click on the upload button, and see if that makes a difference.

4 Likes

If I knew before that you had the picture on a USB stick I'd have suggested moving to the computer before uploading, my first idea of the moment :grin:.

This makes me think that the website isn't accepting the picture format, because once you moved the picture to the computer you excluded the possibility that the website wasn't accepting a file from an external drive and then once you tried to upload a screenshot that's saved as .png this can show that the website reject the picture format. I noticed this during some uploads but I don't remember the situation. Or maybe the website wasn't making my file manager display all pictures formats. These are weird reasons, though, and I'm not aware of how many websites wouldn't allow uploading any kind of picture format the user want. Also, because in that case the user would only get this kind of problems and take days to figure out the reason. You may want to read the website rules and find a help article where it says the supported upload formats.

Here's what you can do to test the issue:
:point_right: try uploading the picture both with an upload button or drag and drop as zenzen said (by the way, this is unlikely, both ways are meant to do the same, upload)
:point_right: do the same as above :point_up_2: but this time with different picture formats. Try with any picture you have, download some or simply change the .png of one into .jpg, .jpeg, .tiff or any other picture format you want.
:point_right: THIS IS FOR ADVANCED USERS, if you're using Firefox like me, try to upload the same picture that's failing > press f12 (opens Firefox developers console) > click the first button on the right zone on the console top bar (opens a small container inside the console itself) > deselect Warnings, Logs, Info and Debug and let only Errors highlighted (will display only errors logs from the webpage) > at least one of the error logs you read there must contain details about the upload failing, so you can right-click there and paste here on a message to show us

This is an example of the console appearance :point_down:


As you can see, I'm indicating the first button to click on the console and Errors logger that's the only filter enabled.

I am using Librewolf and have looked at the Setting for it. I may not understand how the 'privacy' works there. So far no joy.

Can you upload any other picture to that site? Maybe the picture you are trying to use is just slightly larger than allowed or something.

1 Like

Yes, I have tried other pictures (and other sizes), but no joy. I would like to think its the site, but others have uploaded their photos lately so that's not it.

So looks the browser is blocking the upload for privacy/security reasons, I never had an issue like this though, and I'm using Firefox with restrictive anti-tracking protection. New workaround: send your picture to another device of yours and upload it from there.

1 Like

I agree with Luca, you should rule out the usual suspects by trying using different browsers as well as different devices.

If none of that works then it's possible that after so many attempts, your account may be flagged as spam. Either way, it's probably worth reaching out to the admins on that site and let them know about this issue.

3 Likes

Interesting, that's something I didn't anticipate.

This would have been my next and last advice :smile:.

1 Like

Good thoughts Luca. I will contact the site for their attention to this matter. I do not have another device that I can upload from. We remain a no cell phone family and I don't connect my tablet to networks. Android OS remains cumbersome in its file structure for me. I prefer file structure to be mapped out and logically named which Android does NOT do.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.