Playing GTA 5 Online on Steam on Zorin

Hey everybody, I am new :slight_smile:

Short version of my question: what is the current level of playability of GTA 5 Online on Zorin OS?

Longer story...

I started trying to use Zorin OS about a month ago (or even over a month ago). It looks and feels very nice, covers most of my needs, including - at the beginning - the gaming part of it!

About a month ago, I managed to play several games on it, including the one I play most - GTA 5 / Online on Steam... However... at some point during the last month it stopped working... So I had to use Windows for a while...

Now, yesterday I started to try using Zorin again and also running GTA 5... Same thing - it just don't start. When using Proton Experimental and pressing the "Play" button on Steam, it waits a second or 2 and then just turns back to "Play" button, doing nothing. The best I have achieved this far, is that I tested different Proton versions and deleting contents of compatdata folders under Steam. When doing so, I discovered that Proton 5.0-10 is the latest one that installs Rockstar Social Club and even gets as far as trying to load it... but then waits for... a minute or 2 and then Social Club failure message... Earlier versions of Proton doesn't get that far, but some of them manage to install Social Club too.

Is this just my problem? Or is it more general, like Rockstar changing launcher/game so that it does not work on Linux before someone finds a way to make it work? If it is just my problem, can anyone give me a good idea how to debug this? I tried to understand what kind of logfiles are there, but... can anyone guide to right direction?

Hi and welcome to the forum :slight_smile:

Since I do not play any games I cannot help you.
But our volunteers @Michel @storm @StarTreker could be able to help you.

Download the gloriouseggroll proton and try again. Experimental on steam i would not even try.

1 Like

Anyone tried Stadia or GeForce now- electron gaming on sky in Linux?

I agree with Michel, once you have your game installed, right click the game in the left list, click on properties. Go to the compatibility tab, make sure your enabling Steamplay Proton. Force a check to use PROTON version 6.3.

Try launching the game. If the game doesn't launch or play properly, go back to the compatibility tab under the games properties, and choose 1 version lower. Continue doing that until the game launches and plays right.

Also, please make sure that you are running proprietary drivers for your GPU, that is very important. For Nvidia GPU's, you can select your driver on Additional Drivers. The newest current Nvidia driver is 495.44.

Stadia was like a multi-billion dollar experiment that went bad. Nobody takes Stadia seriously these days, and thats because its terrible.


Yes, I already did exactly what you wrote :slight_smile: As I wrote in my initial post - I tried many Proton versions and 5.0-10 was able to install and launch the launcher. I tried lower versions too, those did not get that far...

Unfortunatelly I wrote my answer to Michel into wrong topic and forum does not allow me to copy it. It is here:

Short version - I don't know how to properly install Proton version so that it would display under Steam selection...

Of course I have Nvidia driver, but... I have 470.82.00. I have upgraded the system regulary (and even the install was not that old), but last time I had to quit using Zorin exactly because I tried to switch driver version manually and then - it basically destroyed my system's networking capabilities. So I had to reinstall entire operating system... But OK, I will try to switch to:
NVIDIA driver metapackage from nvidia-driver-495

Adding later: changing Nvidia driver made it slightly worse - now it displays Rockstar launcher with Proton 5.0-10, but it does not seem to even load. Yesterday it showed loading animation.

Anyhow, I think I have to find a way how to properly install that Proton-6.21-GE-1.

I using experimental Proton.