Previously working Zorin install is now giving me IOMMU errors on boot

Imgur

Earlier on, I had the absolute genius idea to go fiddle with one of the computers in the house. I had decided to undervolt the one computer we have running Zorin to try and help it run cooler and give it a longer life, which was unsuccessful and I also may have reset the bios by accident when trying to see if there was a BIOS update available, while foolishly forgetting that that computer updates via USB drive.

After doing all that, I tried to boot ZORIN, only for it to tell me that it was unable to read the IOMMU perf counter. This is not the first time that I’ve encountered IOMMU issues with that machine; I spent about an hour trying to find a fix while doing the original install of Zorin, but I managed to find a way around that. This computer is running an MSI A320M-A PRO MAX with an AMD Athlon 3000G.

In terms of what I remember trying, I’ve tried booting into safe mode, making sure that both IOMMU is enabled and SVM is enabled. A link to an image of the error has been attached via imgur.

Help would be greatly appreciated.

Have you tried adding “iommu=soft” to your grub?

1 Like

I didn’t think of using iommu=soft. Doing that hasn’t resolved the problem but it has changed the error message. https://imgur.com/a/PmxH0nk

Hmmm
You could also replace that with “iommu=pt”
Failing that, you might check your kfd rules located /etc/udev/rules.d (you MAY need to remove the grub changes above)
Ensure the following

KERNEL==“kfd”, GROUP=“video”, MODE=“0660”

Then set the policy in terminal with

restorecon /etc/udev/rules.d/kfd.rules

If still no-go, may need to up your kernel to a different version, though I would think 5.4 would have this in the bag by now.

iommu=pt gave me the original error message but I have been able to load Zorin fully by installing the SSD from the failed undervolt PC onto my main PC, which uses FX-era hardware and it booted almost without a hitch. Some things on it, such as the settings menu, which now takes you through a black screen “circle” once clicked, have glitched and somewhat laggy, so I may consider a re-install, particularly as I have now got the data entered since the last back-up off of the drive. I’ll have a think in the meantime and try and find the kfd rules. Despite my limited (~170 hours) experience of mostly Ubuntu and Ubuntu-derived Linux, I think I should have no trouble finding this.

Kernel is currently a relatively recent version of 5.4

Edit: I couldn’t find it. How does one go about checking the kfd rules?

Edit 2: Fixed it! re-flashing the BIOS was what it took to get past the error. I also reinstalled the OS, but that was largely due to the glitching that was occuring when loaded into another rig.