Printer not working after the latest update

Total newbie here. After the latest updates, my printer doesn't work anymore. I tried all sorts of debugging and troubleshooting, reinstalled CUPS, up to the point I ended up like: https://i.imgur.com/nnu84s2.png

But even after fixing that, the printer doesn't work. Brother printer support told me it's none of their business and it's an OS problem. This is the error msg, when I try to clean heads: {'cups_connection_failure': False} printer doesn't work - Debian User Forums and none of the fixes from there helped (considering I did them right).

If someone is available to do a Team Viewer session and help, I would appreciate it, cause at this point the only thing remaining is to bang my head on the wall.

Have you tried rolling back to the previous kernel? I had problems with kernel 28 causing my laptop to lock up. So rolled back to 27 and no problems. Then when 30 came out I went to it with no problems. So you may need to roll back until the next update.

Thanks! Actually, it's not just the latest update, my printer doesn't work since early January and I think several updates were introduced since then, right? Also, wouldn't I risk from a security point of view? The security updates are done for a reason, right? I cannot just roll back I think and also that's not an option for me. I'd rather fix the printer instead of rolling back.

If since early Jan, we would have a hard time really settling on which updates you received that may have caused the issue. I would treat this as if it was a new issue on a fresh install.
Security updates are a separate thing from a Kernel Update. You can roll the kernel backward or forward, keeping the same security updates.

Can you please note your Make and Model of Printer?

Sure, it's Brother DCP-T310.

You may need the following patch from Brother:
https://support.brother.com/g/b/agreement.aspx?dlid=dlf105260_000&flang=4&c=us_ot&lang=en

Disconnect the printer before installing the patch.
Then to install:

dpkg -i brotherlegacyusb-1.1.0-1.all.deb

Steps I took.
1- I've disconnected the printer
2. Installed it: https://i.imgur.com/f9Mw7Yx.png
3. Restarted Zorin and connected the printer

If I go to Printers it's: https://i.imgur.com/R3LMNVC.png
I start the service, click on Connect https://i.imgur.com/zy97Hre.png and I get https://i.imgur.com/bjXTNea.png

@woyomi8424 Please attach screenshots using the "Upload" tool in the Reply Box toolbar. Some members avoid viewing them on 3rd party imaging sites.

Can you please try the suggestion posted here:

Unfortunately, Draco's steps from there are not that clear for me, starting with 4. If I just choose my printer there it's usb://Brother/DCP-T310?serial=SerianNumberHere

Then, at step 6 I can't find my printer IP address, or at least it's 192.168.1.7 from a report with avahi-browse --all -t -r

But that also doesn't work for me. It just returns: Processing and that's it.
QZBTn20

Same, everything makes sense (I think you did everything correctly so far) to me except for ping PRINTERHOSTHERE < I do not know what you are to replace the all caps part with...

Tried all sorts of solutions from the web, nothing works for me, assuming I did them correctly. It seems to be a problem between CUPS- the latest Zorin OS. Can I see when I installed my OS to see what OS version was that so I can rollback? Also, can I save my actual state of OS on a stick and revert everything if rolling back doesn't work?

cat /etc/os-release

To find when you installed the OS:

Many use Recuezilla for this, though I have never used it myself, so I can offer little in way of a guide on how to. I am told it is quite easy.

1 Like

Very simple to use just follow the instructions only about 4 steps ..... I use it all the time going to do another save sometime today ..... you just put the app on a boot able flash drive as it will install from there .... I have to change my boot order because I dual boot with Win 10 .... but that is no big deal either ....

Shut down your computer ..... install your Rescuezilla thumb drive .... boot into it ..... connect the device you want to save to .... be sure you can recognize that device's name as you will need that later ..... follow the instructions

Maybe some others can add to this ..... not sure if there is something in the Tutorials & Guides .... French Press got me started on using Rescuezilla ....

Looks like I'll just have to admit that for now, I won't be able to use my printer on Linux :man_shrugging:
It's pretty bad and nothing worked for me. If someone knows how to explain Draco's steps in a simpler way I think there's the key.

1 Like

Sorry I can't help you because my DCP-T500-W is Wifi connected and I spent days looking for the answer as to why suddenly my printer would not work ..... I literally threw my hands up and went to Win 10 when I needed to print ....

But I kept after it until I believe it was swarfendor437 showed me a work around using a different printer specks to enable me to print again .... but while I can print I can't scan and have to turn off my VPN to use the printer.... but at least I don't have to revert back to Win 10 ....

I personally feel it is a CUPS fault but unfortunately I have found no other program to use here on Linux .... and yes Brother is really no help just blame's the other guy ..... easy and cheap way out ....

If I find or hear of anything I'll let you know as I have bookmarked your post so I can find it again ..... good luck

Thanks! I've decided not to quit this OS because it has huge potential and instead I am going to dig in deeper to try to find a solution for this, it seems like a quite common problem. I'm also gonna hire an expert if not and one way or another. I'll have my printer working with this OS, considering it worked before. I'll post the solution here in this thread once I'll have it.

1 Like