Printer not working in Zorin 16 (Canon MP190)

My printer that works fine on Zorin 15 won't print on Zorin 16. Zorin 16 recognizes the printer is there and identifies it correctly but when I tell it to print nothing happens. No errors or anything, but it never prints. I just discovered that problem so I haven't searched for a solution yet.

I see, which printer do you have ?

Thank you :sunglasses:

A Canon MP190.

A post was merged into an existing topic: Problem trying to download from WineHQ

Did you try this ?

No I haven't tried anything yet. I just discovered the problem a few minutes ago. Thanks for the link, I'll give that a try.


I created a new thread for your printer issue.
It is all yours :slight_smile:

1 Like

Thanks FrenchPress. When I tried the link Michel gave me the first command worked but the second command "sudo apt install scangearmp2" came back with an error that scangearmp2 could not be found. So I am trying ghostscript but it doesn't seem to want to work either. This printer worked fine on Zorin 15 but doesn't do anything on Zorin 16 even though 16 recognizes the printer correctly. The only other difference is that I am using a different desktop now but I don't think that should make any difference.

1 Like

I think you have to update your local repository by the following command after adding the PPA:

sudo apt update

Then try the second install command.

I tried the sudo apt update and then the second command and got this:

At least I am getting pretty good at uploading screenshots.

This is the only thing i could find

Can you take all available updates?

sudo apt upgrade

If this all fails you could try 32bit driver Michel was talking about.

Super vintage driver from 2008.
But worth trying.

Okay I did the sudo apt upgrade and that all seemed to go okay. But my printer still doesn't print with no errors except before and after I did the upgrade I noticed a quick window that pops up at the top of the screen that says printing cancelled. I have just downloaded the printer file from Canon that the link Michel posted sent me to but I don't think that is going to work because it says it is for a 32 bit system. Ok I will try the 32 bit driver.

I tested that myself.
You are right.
Unmet dependency :frowning:


Did you try this command yet?

sudo apt install cnijfilter2

I wonder how the printer was working on Zorin 15 with no problems. Aren't 15 and 16 both 64 bit?

Just tried "sudo apt install cnijfilter2" came back package not found.

There was a 32bit version for Zorin 15.
Zorin 16 is 64 bit only since Ubuntu dropped 32bit support.

Then I guess that explains why it doesn't work now. When I tried using ghostscript it kept saying that it couldn't find a drive either. Well I do still have my old desktop with 15 on it so I guess I can use it until my ink is gone which usually doesn't take long. Then I have a couple of newer HP printers I can try for 16. This old Canon has just worked great for many many years.

I checked all supported models:

I did not see MP190 in the list.