Problem with bluetooth headset

hello,
I cant seem to connect my bluetooth headset, clicking on bluetooth settings i can only see my mobile phone's bluetooth with a message reading visible as 'name' and available for file transfers. I can't see my headset's bluetooth I tried blueman but still got the same issue
any help is appreciated
Device: Dell Vostro 3491

thanks.

What make and model are the Headphones?

What is the terminal output of

sudo lshw -C network

Some things you can try:
Make a back up of your ~.config/pulseaudio file

mv ~/.config/pulse/ ~/.config/pulse.bk

Restart the service

systemctl --user restart pulseaudio

Reinstall the software and install pavucontrol

sudo apt install --reinstall pavucontrol pulseaudio pulseaudio-module-bluetooth

Launch pavucontrol:

pavucontrol

Locate your audio source and set the playback device to your headphones and test.

my headset is boat rockerz 235v2

how do i do this ?

additionally i installed bluetooth adaptor from software store which lead to my device recognizing a couple of extra bluetooth devices but not my headset

what exactly do i provide here as there is a bunch of information that i don't know what they mean?
Thanks

In Pavucontrol > Output devices > port - look for your device in the drop down menu.
You may have multiple Ports depending on your hardware. For example, audio over HDMI and audio over the built in stereo...

You mean, for sudo lshw -C network?
What we are checking there is the Radio Driver. Wifi and Bluetooth both use the Radio modules / Drivers. It can help to check the drivers for the radio device if Bluetooth is not working.
Look for description: Wireless interface
You want to relay product, vendor and configuration at least.

You can PM those details in a private message if you are confident in the member helping you in thread to prevent that information being publicly displayed.

1 Like

in pavucontrol all i can see is device speaker and (unplugged)headphones I can configure that when i attach a wired headse, so I am guessing thats not the bluetooth headset, bluetooth headset still seems to not be connected.

Output for sudo lshw -C network

*-network
description: Wireless interface
product: QCA9377 802.11ac Wireless Network Adapter
vendor: Qualcomm Atheros
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath10k_pci driverversion=5.15.0-52-generic firmware=WLAN.TF.2.1-00021-QCARMSWP-1 latency=0 link=yes multicast=yes wireless=IEEE 802.11

Do tell if i need to provide additional info
thanks,

Can you please try:

sudo apt install --reinstall linux-firmware blueman

Use Module Prober to try to jostle it:

sudo modprobe -r ath10k_pci && sudo modprobe ath10k_pci

Launch blueman and try to pair the headphones.

-I edited your post to only include necessary net driver info.-

1 Like

This fixed it, thankyou very much.

1 Like