Problems after upgrading to Zorin 17

I recently upgraded from Zorin 16 core to 17 core. Everything went without any problems.
But when I tried to watch a movie on arte-tv it didn't run smoothly, actually it ran hardly at all. The same on media centers of the other german public broadcast channels where I once got the following message:

Youtube seems to run, though.
At first I thought it was a problem with the firefox browser. So I installed another one (Vivaldi). But the problem stayed the same.
These are the specifications of my computer:

Is there any helpful idea?

Something to try: Log out then Login again but at the login prompt look for gearwheel bottom right of screen. Click and select "X11" instead of default "Wayland" and see if that helps.
If not choose Wayland next login.

Welcome to the Forum!

The first Picture shows a Geoblocking-Error. That means that the Page think You are not in Germany. Do You use a VPN? If Yes You should disable it. Or are You not in Germany?

2 Likes

Thanks for the hint! No, I'm not using a VPN.
But that geoblocking error message I only got that one time. So I don't take it for serious any more.

I'm sorry but I didn't get what sort of login you mean. Do you mean starting the computer?

I mean the ZorinOS login screen, that shows prompt to enter username and password.

I've now put X11. But unfortunately nothing changed.

So the Videos run now without a Problem?

According to PeMe57's last post. Not working on Wayland or X11.

@PeMe57 Do you just have Intel graphics as your earlier screenshot?
Have you checked for any graphics driver updates?

No, unfortunately not. I don't get any error message any more, but videos don't run smoothly. It's a continuous stop and go while the audio is running.

1 Like

Yes, I have the graphics of the screenshot. I'm updating my software regularly and it tells everything is up to date. So I suppose the drivers are as well.

  • What I don't understand, is that everything worked fine under Zorin 16. So I'm on the way of regretting to have done the upgrade.

I wonder if it is an issue with the latest Z17 kernel.
Try booting to grub screen, select Additional Options for ZorinOS and select older version of linux kernel (gereric) and run that to test.
Report back results which kernels you have tried.

2 Likes

Is there a danger of data loss if I follow your suggestion?

There is no such danger. If the different kernel does not work, you can just reboot to boot into the default kernel.

Meanwhile I had the time to test different kernels as zabadabadoo suggested. The kernels that I could opt for were: 6.5.0-18, 6.5.0-17, and 6.5.0-15. But none of them solved the problem.
Regarding the graphics Z11 seems to run a little smoother (the goes between the stops are a little longer) but Wayland is better for scrolling pages on the touch screen.

I am repetitively asked to "Highlight the answer and help others by using the solution button below the correct reply." But my problem still remains as it was since I upgraded to Zorin 17 and the suggestion of Zabadabadoo, Ponce-De-Leon and Aravisian - for which I'm grateful - unfortunately didn't solve it.
I wonder if there isn't any other person with the same problem. It must be a software problem because under my Windows 10 partition films run perfectly.

The issue seems to stem from Hardware Acceleration. Steps you might try is disabling Hardware Acceleration in your browser or reinstalling the Ubuntu 22.04 OEM kernel:

sudo apt install --reinstall linux-oem-22.04d

Looking for answers across the web, I found a few hits that may be similar to yours. The Intel Iris is a frequent topic here on this forum, as well.
A Redditor posted this suggestion; please be sure to read the responses, as well:
https://www.reddit.com/r/linux/comments/108qtd2/fixing_gpu_hangs_on_intel_hd_graphics_520_and/

Did you tried it with ubuntu-restricted-extras installed? This is a Package with extra Codecs that are seperate because they are not Open Source. There are Codecs in it and Microsoft Fonts. So, when You install it there will come a Screen with a Licence Agreement.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.