Programs can not find websites

Hi Zorinistas, I've got a lovely new problem for you to spice up your Sunday:
When I try to open web pages or emails on my desktop pc with Brave, Thunderbird, Firefox etc. I get the popup "the address could not be found, DNS probe possible".
Network is ok with a good connection which I'm currently using to send you this message using my laptop (using the exact same ethernet cable - I don't use wi-fi). The applications can't seem to access the internet.

This is not associated with a new system install, everything's been running fairly smoothly (though slowly but that's another story) for a while now. The only recent major change (and a possible culprit) is that I installed Proton VPN recently, which now doesn't work either by the way.
I didn't install the VPN on my laptop and Brave etc all working fine on there.

I'm on Zorin 16 on an old home made system based on an Asus P5KVM motherboard.
I've had a bit of a look around this and other forums but can't find anything that works and is also comprehensible to me at the same time!

What I have tried, after switching things on and off, swapping computers around etc. is:

1 Disabled IPv6 for the connection in question. In network settings but not at the router (could try that next).

2 Tried to disable the VPN kill switch (can't actually remember if I activated it or not though) by inputting:
"protonvpn-cli"
"protonvpn ks - - off"
"nmcli c delete pvpn-ipv6leak-protection"

I used the vpn a few times before this present problem occurred and on those occasions all was ok.

Would deleting the vpn help? Then reinstall but remember to never touch the kill switch (fortunately i don't have any reason to believe that my life will be endangered if any of my activity is seen by a malicious actor)?
Or it might not be the kill switch?

Hope you're not all sleeping off your sunday lunch!

You're correct, VPNs tend to cause this type of problems as they update your system to use their own DNS service. I would suggest re-installing, but go over to Proton VPN's documentation page and follow their exact instructions on this, as you want to make sure you're not leaving any modified files and/or settings leftover.

Yep, I agree.
ProtonVPN places a Configuration File on your system and modifies a different one.
Those changes remain even if you remove ProtonVPN, causing the net to not work or not work correctly.

Also:

sudo nmcli connection delete pvpn-killswitch

rm -rf ~/.cache/protonvpn

rm -rf ~/.config/protonvpn

1 Like

Thank you both, something's come up just now though so I'll try all that tomorrow I hope.
J

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.