Question On Zorin Desktop On Xborg

Never thought I would ever say this but I have left my beloved Cinnamon DE for Zorin Desktop on Xborg ..... and so far I have customized it very successfully all except one item ..... the bottom task bar .....

I can't seem to find an option to allow much used apps to be anchored to the taskbar ..... there is a icon the last one on the very bottom left with a solid white color ......

It can be opened and will display all the open apps and this is fine ..... except you must click on it to see all your open programs and click on one to open it ..... If you should close the app without minimizing it it will disappear from the icon and you will have to add it again if you wish to continue using it ....

I much prefer to have the icons I use constantly visible in the task bar so I can open them as need be .....

Please see the photos below .....

1st photo ..... desktop screen showing lack of pinned apps except for 3 .....

2nd photo ..... the white icon when opened it shows 4 apps opened .....

Terminal
Zorin Forum
LibreOffice
XnView MP

3rd photo ...... what I would like is something like this .....

Do you mean pinning programs to the taskbar so that you can launch them, minimize, focus them, etc? If so, you first need to have that program already running and then right-click on its icon at the taskbar and select "Pin to Dash".

sc2

1 Like

Yes normally that would work but for me when I choose Pin to Dash it says it is pinned but doesn't show up ...... I also have a Pin to Desktop and it seems to work as shown in the picture below ..... but as to Pin to Dash I have no idea where they go to .....

Do I need to download something called Dash ????? .....

All of these were committed to Pin to Dash and Pin to Desktop these run vertically ...... ??????

If you right-click on the taskbar, on an empty area, and go to Taskbar Settings -> Position: do you have the "Taskbar" widget disabled?

1 Like

Thanks zenzen you put me on the right track ....I found on the web that Pin to Dash meant dock to dash and could be found in Gnome Extensions .... it was turned off so I turned it on and then went to Zorin Appearance and choose a Layout that showed Icons on the bottom which is the first one and now I have my icons back ....

Thank you kind sir ....

1 Like

It's a bit strange since the taskbar icons should also work on the desktop layout that you were using. In my screenshot you cannot see it because I purposefully turned it off, but it works fine otherwise.

Anyway, I'm glad it all worked out :slight_smile:

1 Like