Razer Headset not showing mic as option (single jack connection)

Hello!

I am on Zorin pro and was trying to connect a Razer headet. It picks up the headphone part no problem, but doesn't seem to pic up the mic and as such I can't use it. I don't see it listed in Pulse either. I wasn't sure if it could be a driver issue, but any help is appreciated! Thank you!

Can you please run in terminal:

rm -rf ~/.config/pulse/

Log out and in or reboot, then run the configuration editor for your mic and sound settings to see if the mic is recognized.

If not, in terminal, please run

alsamixer

Ensure nothing is muted with the MM at the bottom of the bar.

No luck with the rm -rf sadly.

This is what is showing withing alsamixer

1 Like

In alsamixer try toggling [Loopback] and see if that has any effect.
You can also try same with [Auto-Mute].

I see 3 channels marked as Muted i.e. MM. Unmute them by selecting the channel and typing M.

From experience, sound issues often involve trial and error experiments.

Still no luck unfortunately, I unmuted them and enabled, but it still isn't listing the microphone as an input option

If this helps, I tried another 3.5mm headset and had the same issue so it seems like it might be the jack itself. It worked fine when I had windows so I'm not sure whats going on

Is your headset listed under Supported headphones or Other dvices that work on this page for the Razer open source DKMS drivers?

Its not unfortunately, but I did also try a non-razer headset and have the same issue.

While possible, I wouldn't place my first bet that the jack itself went out at the same time you switched OS's...
But I wonder if the jack hardware driver is what is not working.
Can you please relay the terminal output of

sudo lshw -C multimedia

Thank you, this is what returns back

*-multimedia              
       description: Audio device
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0.1
       bus info: pci@0000:01:00.1
       version: a1
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:17 memory:a4080000-a4083fff
  *-usb:1
       description: Video
       product: USB2.0 HD UVC WebCam
       vendor: Azurewave
       physical id: 9
       bus info: usb@1:9
       version: 17.01
       serial: 0x0001
       capabilities: usb-2.00
       configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
  *-multimedia
       description: Audio device
       product: Comet Lake PCH cAVS
       vendor: Intel Corporation
       physical id: 1f.3
       bus info: pci@0000:00:1f.3
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=32
       resources: iomemory:600-5ff iomemory:600-5ff irq:158 memory:6043110000-6043113fff memory:6043000000-60430fffff

This looks correct.
However, the following does not:

You can choose which of the two methods below you prefer:
CLI
Please open a terminal and run

sudo apt update && sudo ubuntu-drivers install

Once done, reboot and test your devices.

GUI
Open the App menu and type in Software and look for Software & Updates to be offered in the list of apps. Select Software & Updates, then move to the Additional Drivers tab to start the Jockey program. Jockey will take some time searching drivers, this is normal. Shouldn't be longer than about 50 seconds, though.
Select yoru Nvidia driver from the list created, using the Checkboxes.

If they above does not quite get things sorted out, try the X-Swat up to date drivers. In terminal, run:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

You can use Software & Updates to perform the above X-swat as well, paste the link under Add a repository in the first tab, then refresh the cache when you close. Then run the system upgrade GUI tool.
The terminal is a lot faster and easier...

The above should ensure that the proper Nvidia drivers are installed and utilized. This seems likely to affect your headset issue - though I cannot guarantee that without knowing for sure that the missing driver was the cause... Please update this thread once Nvidia drivers are installed and running.

What model headset it is?

I guess another option would be to try a USB headset/mic.

Dongle usb where you have two input plugin jack microphone and audio.

Sadly still no luck. It does seem like something happens when switching to Zorin. I do have windows dual-booted now and it works fine there.

I am sorry @GrubbyGroo but I am at a loss at this point. Perhaps:

may be the reasonable path forward...

No worries, thank you for all the help!
I actually heard back from the zorin support team and they provided this option which looks to have resolved it.

To resolve this issue, please open the Terminal (Ctrl+Alt+T) and enter these 2 commands:
echo "options snd-hda-intel model=dell-headset-multi" | sudo tee -a /etc/modprobe.d/alsa-base.conf

sudo update-grub

Afterward, please restart your computer to apply the changes.

2 Likes