Recent update to Zorin 17 pro has broken Nvidia

Hi.

Recent update (around 26/05/2024) has broken my gaming ring. At 1st odd games stopped working. So I reinstalled 550 driver this made things worse with non of the games across Steam/Lutris/Heroic working. Also random screen freezes and freezing when waking up from suspension. At this point I went down the route of manual installation of the Nvidia 550.76. But immediately got the error that the kernel was built with gcc-12 error. So I followed Ubuntu 22.04 default GCC version does not match version that built latest default kernel - Ask Ubuntu to build the 550.76 drivers. Now there are no more screen freezes unless I attempt to play a game. All games still don't work and causes a screen freeze.

Hardware:

  • Nividia 3060 12GB

Thank you in advance for any help!

If caused by software update, have you tried booting a previous version linux kernel generic, from the grub menu item "Additional Options for Zorin"?

1 Like

@zabadabadoo Thanks. Haven't thought of that. Will try and see if booting older kernel would help. Unfortunately I've may have to rollback all the manual changes that I've done so the earlier kernel functions as expected.

It is important to note that Nvidia's drivers are not always as good as the higher number. My machine also has RTX 3060, but the driver has not been changed from the default 535.

1 Like

@Hackgets I usually tend to agree with you but I've started playing some games that I can only get working in flatpak. I've never managed to get SF6 to work outside of flatpak. And I just upgraded the Nvidia drivers as it didn't seem to affect flatpak steam/lutris/heroic. Honestly hate Nvidia! This doesn't happen with my Steamdeck and I have the same setup there. The only reason I stick with it is because I'm trying to teach myself ML. I think for my next setup I'm going to go with Radeon and use external Nvidia for ML.

Anyway I think I've fixed it! Followed [HOW TO] Install the latest Nvidia driver on Zorin OS 16 & Pop! OS 21.04. The important step seemed to be:

sudo apt remove --purge ^nvidia-.*

It removed a heap of libs including flatpak Nvidia libs. Which needed to be reinstalled upon Steam start. There may have been some stale libs, which were causing issues. Now at least the games are working. Will have to wait a while to rule out random screen freezes.

Thanks everyone for the help, much appreciated.

1 Like

Argh! Random crashes are still happening! But at least the games are working now. I've had this problem since Ubuntu 20.04, you just learn to live with it. Thanks Nvidia :rage:

In fact, I got my current machine to use machine learning. Linux-based system is often used in this field and Nvidia seems to be trying to support it. I hope this problem will be solved.

The Flatpak issue has been widely discussed. In my opinion, it would be an unsuitable system for performance-demanding applications such as gaming.

1 Like

Thanks @Hackgets. I have been looking at the logs and saw some serious problems that could be causing this error, but can't figure out why it would cause a halt.

WARNING: discarding _NET_WM_PID 13 as invalid for X11 window - use specialized XCB_X11_TO_PID function!

This is caused by using an NTFS partition with Proton. I believe the system hanging isn't part of the GPU issue mentioned in OP, so I'm going to close this issue as solved.

Just to give you some context. I switched from Windows gaming about a year ago but all my games were stored on an NTFS external drive. So rather than redownload 6+TB of games, I decided to use this workaround when I switched, Using a NTFS disk with Linux and Windows · ValveSoftware/Proton Wiki · GitHub. I believe the drive is nearing it's end of life and that's is why I'm seeing these system freezes.

1 Like