Removed gnome shell

Help. What do I do?

Try Ctrl+Alt+F1 (may be F1-F6). If that doesn’t get you back, logon with user and password (same as if you were on desktop GUI), then type startx

PS - You’re most likely messing up your username. I’ve done it too when on this virtual terminal.

The graphical session is usually on Ctrl+Alt+F7 on my machines.

I did this by mistake.

sudo apt-get remove gnome-shell-extensions

You can rectify that by using the same command with install instead of remove
Note what @phunsoft wrote - you may have to play around with the function keys to toggle between desktop and terminal.

Not worked.cant share image as too large.

sudo apt install gnome-shell-extensions did not work? What messages are you getting? What about startx ?
If not, try sudo apt update && sudo apt upgrade and then the first two commands again.

Got desktop now but nothing loads but terminal. Nothing at all will run.

Type zorin-desktop-session in terminal. If that doesn’t work, try gdm3 and then again zorin-desktop-session

Only the root user can run gdm

Use sudo and then those two commands (as needed).

Nope. Nothing. I have really messed up this time.

Can you uninstall tweaks from the terminal?

So, no messages from running those commands, correct? Just no results, correct?

Yes, you can do anything and everything from terminal. sudo apt remove gnome-tweaks

Also look into:
These are my best guesses on packages that may have gotten messed up.

It worked but the system hasn’t changed. Still can’t load any app except Terminal. zorin dash doesn’t load.

If you have Synaptic installed, it will be quicker. Launch it using synaptic or sudo synaptic. Then just search for all those packages I listed (including the gnome-shell-extensions that you identified earlier) and mark each of them for complete reinstallation and then Apply.

Not sure about Synaptic. Tried the other way first.

Got things working again but now the login screen is not the same as it was and not the wallpaper that is chosen in settings.

On login screen, click the little cog/gear wheel and see if you accidentally selected Wayland or some other desktop scheme other than Zorin.

It turns out, all I had to do was to go into Users and click unlock, put in my password and then turn the switch on for Auto Login.

1 Like