SCID (Chess program) Grab failed:Window not viewable

So I am trying to use the program SCID, which I installed via the command line. However, I was messing with the settings when I booted the program up from the GUI and I messed it ALL up. To where none of the windows were showing. So, I uninstalled through the Software section in Zorin, then used the command line to install using the command
Sudo apt-get install scid
For a while I could go into the folder in the command line and sudo into the program and it would display the GUI program for me. Just so were on the same page SCID is an indexing program for Chess. It allows you to install an Engine to evaluate chess moves and it spits out the best solution to the given position.
So, for a while going through the CLI worked, and Sudoing into scid from the folder it was installed in by default worked. But now here recently it will not work. Instead I am met with the following response.

root@sandwich:/usr/games# scid
grab failed: window not viewable
while executing
"grab $w"
(procedure "progressWindow" line 33)
invoked from within
"progressWindow "Scid - [tr Spellcheking]" "Loading $spellCheckFile ...""
(file "/usr/share/scid/tcl/end.tcl" line 1290)
invoked from within
"source -encoding utf-8 [file nativename [file join $::scidTclDir "$f"]]"
("foreach" body line 2)
invoked from within
"foreach f $tcl_files {
source -encoding utf-8 [file nativename [file join $::scidTclDir "$f"]]
}"
(file "/usr/games/scid" line 584)

I won't lie I am not extremely proficient in CLI, but I know enough to get me around. So if anybody could help me it would be greatly appreciated. I just want SCID to work, it is a superior chess indexing program in my humble opinion.
Thanks in advance my fellow CLI users! ILY and hope you have a good day!

This immediately makes me wonder if the settings you set were stored in your home configuration directory. This would not be removed by a simple package removal (Uninstall) and upon reinstall, would still be viewable by the app.
Perhaps check your ~/.config directory for anything related to SCID and sudo apt remove --purge scid. Once done clean the apt cache and remove any installed dependencies, just to reduce any chance of a previous corrupted download

sudo apt clean && sudo apt autoremove

Once you have nuked all traces of SCID, try reinstalling.

I base this response on the assumption that it was working prior to changing settings...

1 Like