Screen corruption with google-chrome since last update

Anybody has anybody experience screen corruption since last zorin update ?
It happens when using chrome. It works for a while but at some random point the screen become totally garbled.

google-chrome version: Version 121.0.6167.85 (Build officiel) (64 bits)

My info is below :
``bt@zero:~$ inxi -Faz
System:
Kernel: 6.5.0-15-generic x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/BOOT/ubuntu_hwmpxp@/vmlinuz-6.5.0-15-generic
root=ZFS=rpool/ROOT/ubuntu_hwmpxp ro quiet splash vt.handoff=1
Desktop: GNOME 43.9 tk: GTK 3.24.33 wm: gnome-shell dm: GDM3 42.0
Distro: Zorin OS 17 base: Ubuntu 22.04 LTS Jammy
Machine:
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X513UA_M513UA
v: 1.0 serial:
Mobo: ASUSTeK model: X513UA v: 1.0 serial:
UEFI: American Megatrends LLC. v: X513UA.305 date: 03/12/2021
Battery:
ID-1: BAT0 charge: 32.8 Wh (100.0%) condition: 32.8/42.1 Wh (78.1%)
volts: 11.8 min: 11.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: Not charging cycles: 78
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
serial: charge: 100% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Info: model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x68 (104) stepping: 1
microcode: 0x8608103
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 520 high: 2331 min/max: 400/4372 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400
4: 400 5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400
13: 2331 14: 400 15: 400 16: 400 bogomips: 57488
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: gather_data_sampling status: Not affected
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed
mitigation: untrained return thunk; SMT enabled with STIBP protection
Type: spec_rstack_overflow mitigation: safe RET
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Lucienne vendor: ASUSTeK driver: amdgpu v: kernel pcie:
gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
class-ID: 0300
Device-2: Quanta USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 3-3:4 chip-ID: 0408:30d4 class-ID: 0e02 serial:
Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.1
compositor: gnome-shell driver: X: loaded: amdgpu,ati
unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu display-ID: 0
Monitor-1: eDP-1 built: 2018 res: 1920x1080 dpi: 142 gamma: 1.2
size: 344x194mm (13.5x7.6") diag: 395mm (15.5") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
OpenGL: renderer: RENOIR (renoir LLVM 15.0.7 DRM 3.54 6.5.0-15-generic)
v: 4.6 Mesa 23.0.4-0ubuntu1~22.04.1 direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: ASUSTeK driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt
pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k6.5.0-15-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp1s0 state: up mac:
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
driver: r8152 bus-ID: 2-1.3:4 chip-ID: 0bda:8153 class-ID: 0000
serial:
IF: enx00e04c68397d state: up speed: 1000 Mbps duplex: full mac:
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-2:3 chip-ID: 8087:0029 class-ID: e001
Report: hciconfig ID: hci0 rfk-id: 3 state: up address:
bt-v: 3.0 lmp-v: 5.2 sub-v: 237e hci-v: 5.2 rev: 237e
Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff
link-mode: peripheral accept
service-classes: rendering, capturing, audio, telephony
RAID:
Device-1: bpool type: zfs status: ONLINE level: linear raw: size: 1.88 GiB
free: 1.58 GiB allocated: 304 MiB zfs-fs: size: 1.75 GiB free: 1.45 GiB
Components: Online: N/A
Device-2: rpool type: zfs status: ONLINE level: linear raw: size: 944 GiB
free: 717 GiB allocated: 227 GiB zfs-fs: size: 914.75 GiB free: 687.22 GiB
Components: Online: N/A
Drives:
Local Storage: total: raw: 1.9 TiB usable: 2.79 TiB used: 228.91 GiB (8.0%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN530 SDBPNPZ-1T00-1002 size: 953.87 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: rev: 21106000 temp: 33.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Seagate
model: One Touch HDD size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B type: N/A serial: rev: 1707 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB model: Multiple Card Reader
size: 59.69 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: rev: 1.00
Partition:
ID-1: / raw-size: N/A size: 694.09 GiB used: 6.87 GiB (1.0%) fs: zfs
logical: rpool/ROOT/ubuntu_hwmpxp
ID-2: /boot raw-size: N/A size: 1.75 GiB used: 302.8 MiB (16.9%) fs: zfs
logical: bpool/BOOT/ubuntu_hwmpxp
ID-3: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 20.1 MiB (3.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/log raw-size: N/A size: 687.29 GiB used: 67.9 MiB (0.0%)
fs: zfs logical: rpool/ROOT/ubuntu_hwmpxp/var/log
Swap:
Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/dm-1 maj-min: 252:1 mapped: cryptoswap
Sensors:
System Temperatures: cpu: 46.0 C mobo: N/A gpu: amdgpu temp: 41.0 C
Fan Speeds (RPM): cpu: 0
Info:
Processes: 597 Uptime: 8m wakeups: 3 Memory: 15.02 GiB
used: 4.55 GiB (30.3%) Init: systemd v: 249 runlevel: 5 tool: systemctl
Compilers: gcc: 11.4.0 alt: 11/12 Packages: 2484 apt: 2414 lib: 1213
flatpak: 70 Shell: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.13
`

Yes, it has something to do with overlays... parts of my screen within Chrome get garbled when I'm scrolling. If I scroll up then back down, it's normal again.

Since most of the overlays are HTML divs used for ads, using uBlock Origin ad blocker really cuts down on the amount of engarblement.

1 Like

On my laptop is also seems related to chrome changing background image when opening new tabs. But I can't reproduce the problem yet. The whole desktop is garbled not only chrome. I have tried setting gpu rasterizing flag to disable and did not have the problem for a while. But now since I changed back to default I didn't have any problem ... So I'm still mystified for now.

Update: It happened once more while changing to a new tab on chrome but the corruption start at the bottom of the screen. It seems to start from the dash at the bottom and all icons are corrupted first. Then the rest of the screen follows.

Have you tried rolling back to the previous kernel using the grub menu > Advanced Options for Zorin?

(AMD Graphics drivers are included in the kernel)

Do you know if there was a new kernel version in last update since 2 days ?
I know that google-chrome had a new version but I don't know if I could goback one version since it is obtained directly from google.

Not in the last couple of days... But when a user sees and implements an updaters notification can vary quite a lot.

I have choosen to wait and did not have the problem again since. But I tried to avoid using google-chrome. I installed the "floorp" browser and I'm very happy with it. I keep google-chrome because I need it to chromecast NHL hockey on TV. I will wait a bit more before tagging the problem as solved.
Thank you everybody for your suggestions. :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.