Screen tearing on Zorin OS 16.1 Lite

I have been experiencing a strange glitch on my screen since that I honestly don't know how to describe. So I recorded a video showing it on the Zorin website:

Any idea how to fix this?
If the glitch is not clear I will try to record another video.

Edit: Finally found the term for it, it's called screen tearing.

You've made the video private so no one but you can view it! We all make these mistakes (I know from recent experience!)

Oops, my bad :sweat_smile:

I set the video to unlisted so that people with the link can view it.

Weird, I didn't see any tearing - but I am due to see the Optician! :grin:

I do not see any either... can O.P. clarify or draw attention to what we need to see?

I had this issue with video.
A few updates later, it seemed to have fixed itself, so maybe try changing your video driver? Additional driver > try another driver?

Also maybe post your specs and we can have a google. i.e Nvidia Force MX250 seems to work well with the 470 proprietary driver for me.

1 Like

It seems that the tearing is not clear so I recorded another video with a screen tearing test that makes it very clear:

Also after some research, this seems to be an issue with the display driver. This message that I get on startup might be related:

[   35.867324] debugfs: File 'radeon_ring_gfx' in directory '0' already present!
[   35.867334] debugfs: File 'radeon_ring_cp1' in directory '0' already present!
[   35.867338] debugfs: File 'radeon_ring_cp2' in directory '0' already present!
[   35.867342] debugfs: File 'radeon_ring_dma1' in directory '0' already present!
[   35.867346] debugfs: File 'radeon_ring_dma2' in directory '0' already present!

Additional Drivers does not show any driver.

I own an Inspiron 15R 5537. This may provide some relevant info:

Screenshot_2022-06-20_16-40-30

Can you try:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt upgrade

I still see no tearing in your video. What this suggests is that the tearing is visible on your screen, but is not recorded in video. It is visible display-side only.

@ecsperitgamar we see no tearing, I assume because the tearing is a function of what you see on your display and not what the graphics are drawing (maybe a Hz misconfig). If you record your screen with your phone, it might be clearer (though other artifacts will also be visible, so maybe take a photograph or choose a single frame with the problem?).

EDIT: I just realized I said what @Aravisian said. See if you can tweak your display frequency settings. I remember having this when I was initially setting up this laptop, and changing it from a given Hz to another fixed it.

Also, do you have fractional screen scaling set?

Here is a photo showcasing the tearing:

1 Like

Unfortunately this did not fix the issue.

I went to the display settings and there were two options: 60 Hz and 40.1 Hz. Both did not fix the issue.

No idea, how do I enable/disable it?

In my system (Gnome), if I go to Settings -> Displays, I see this, and I can enable/disable fractional scaling (the last two options):

Choosing "100%" or "200%" and disabling the "Fractional Scaling" toggle have helped me with screen tearing in the past, in other systems.

Changing the scale unfortunately didn’t seem to do anything, and I use Lite which doesn’t have that option.

Well, I'm out of ideas, sorry! Lite uses xfce, if I'm not mistaken, so yeah, it'll not behave the same.

That is definite Screen Tearing.

GUI Method:
In your app menu, type settings editor and click it when it is offered in the menu.
Scroll down in the left pane to xfwm4 and click it. Then in the Right pane, scroll down to vblank_mode and click on that. Click the "edit" button.
Under Value, replace "auto" with glx.
Click Save.

CLI Method:

xfwm4 --replace --vblank=glx &
xfconf-query -c xfwm4 -p /general/vblank_mode -s glx

Reboot and test...

It worked, thanks!

1 Like