Scroll lock by clicking mouse wheel?

Whenever I want to scroll through something by single-clicking the scroll wheel button on my mouse, that doesn't work! WHY is that not a thing on Linux?! :man_facepalming: :man_shrugging: Or is it more dependent on like the partiuclar distro you choose to use? Anyway, I'm curious to know if there's any way of getting that to work? :thinking:

Anyway, just some random questions I thought of since I'm essentially giving this another shot. For anyone wondering or curious, this pcpartpicker link contains all the components/peripherals of my setup: And if any of y'all happen to have any questions for me or need more details, feel free to reply, comment below or even just dm me if you feel like it & I'll be sure to get back with you! :slight_smile: :+1:

So with that being said, I'll just leave it at that for now & hope someone helpful enough can reply. :crossed_fingers: Thanks in advance to anyone whom can be of help!


1 Like

In Zorin menu > Settings > Mouse & Touchpad, enable "Edge Scrolling" to see if that enables your mouse wheel.

Test your mouse wheel. Issue the command:
xev | grep button
... hover the mouse over the box that pops up, then use your mouse wheel.

... to find the ID of your mouse.

So let's say your mouse is ID 13, you'd enter:
xinput --test 13
... then use your mousewheel, you should see output like:
For moving the cursor:

motion a[0]=654 a[1]=596
motion a[0]=645 a[1]=600
motion a[0]=638 a[1]=604
motion a[0]=628 a[1]=607
motion a[0]=621 a[1]=610
motion a[0]=614 a[1]=612
motion a[0]=607 a[1]=614
motion a[0]=600 a[1]=617

For a click:

button press 1
button release 1

For scrolling:

motion a[3]=43747
motion a[3]=43748
motion a[3]=43750
motion a[3]=43753
motion a[3]=43754
motion a[3]=43756
button press 5
button release 5

You can see the properties of your mouse (again, assuming it's ID 13):
xinput list-props 13

Thanks for the tip, but you should have realized that my pc is NOT a laptop; it's a custom-built desktop & I didn't see "Edge Scrolling" within the settings.

The settings should still be there. If you've got dconf Editor, try going to /org/gnome/desktop/peripherals/touchpad/edge-scrolling-enabled.

Some mousewheels use Edge Scrolling as if they were touchpads. If yours does, enabling it should enable your mousewheel.

I saw what it calls "Natural Scrolling", but I've NO IDEA if that's the same thing... :thinking: :man_shrugging:

No, Natural Scrolling just changes how the window beneath the cursor moves when you scroll... unintuitively, when I enable Natural Scrolling and I stroke downward on the touchpad, the window moves toward the top of the page... the opposite to what it usually does. So I leave Natural Scrolling off.

OH, Huh. Well, I can try what you suggested later & see if it makes a difference. Not a HUGE dealbreaker for me, but it's just one of those "nice-to-haves", you know? :wink: Anyway, hoping some other can reply to help me out with my other inquiries/topics... :pray:

We might be able to get it working for your browser, at least... if you're running a Chromium variant browser (Chrome, Brave, Edge, SRWare Iron, etc.).

Append --enable-blink-features=MiddleClickAutoscroll to the list of flags in the startup for the browser.

Like I said though, I'll consider it if I don't find an alternate solution. But still open to options here... :slight_smile:

Does it happen to be a Logitech mouse?

Nope. It's a Corsair Harpoon RGB wireless. Once the switches in it kick the bucket, I'm going with Logitech G Pro X Superlight as the much better replacement. :+1:

You need to enable this feature on Linux. In Firefox go to settings and on the bottom of the page enable autoscroll. In Chrome you need to edit the .desktop file and add this line.


More info:

Or you can use an extension for that.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.