Secureboot MOK mistake

With latest update for my Intel NUC with Zorin OS 15.3 was asked to create secureboot password and did. When rebooting dialogue said something about MOK (which I did not recognise or understand to be related to secureboot) I clicked continue boot. Now I’m screwed for proprietary drivers. How do I rectify this situation???

If I might ask; do you require Secure Boot to be enabled?
When installing Linux on a system, it really is best to have Secure Boot disabled. In fact, many people cannot install Linux with it enabled, even.
I wonder if it would be better to disabled Secure Boot in your UEFI, then

sudo mokutil --disable-validation

It told me I needed it enabled for proprietary drivers.

As I understand it, secure boot should not be Required for Proprietary drivers:

Rather, it will try to set a PW for the MOK if your secure boot IS enabled when you go to install the Official Nvidia Drivers.

1 Like

I’m just telling you what the dialogue said when I completed the update.

I am not doubting you at all.
But this does worry me- as to what Canonical and Nvidia are Up To Now.
I have been doing a bunch of checking and I have Confirmed that on most systems, Linux cannot be installed with Secure Boot enabled. Some can - and some of them run into other odd problems because of it.
Microsoft Dominates the computer system market. Because of this, hardware is built with Windows, not Linux, in mind.

If something is going on- that I clearly do not understand well enough, that Canonical is requiring Secure Boot Enabled for Proprietary - when this would disable many people- That concerns me.

Do the Open Source Nouveau drivers not perform with your system?