Selected a different layout, now it's stuck, can't change back

... and yes I searched this forum. Tried executing several different commands to restore default layout. Only way I can think to get back to the out-of-the-box default look is to reinstall Zorin.

Very sparse on details for your PC and what version of Zorin you have installed. Consequently I am guessing at what advice to provide.

In the various menus you have the “Appearance” option which gives you several layouts. Was that checked? Did you remove any packages that you thought were unnecessary? Did you install any extensions that modify the layouts or tweaks and change settings? Depending on how long you have been using Zorin, it might be better to do a fresh install.

Many people here are willing to help but you need to provide more details. :v:

2 Likes

ive done the same. TimeShift is your bestfriend after a fresh install. it could be alot worse lol

You might try setting your home config directory back to default. Take Note - this will reset all your custom settings back to fresh install defaults. Not to worry it too much, as we will make a backup:

mv ~/.config ~/.config-bk

Log out and back in or reboot.
Check layouts.

Thanks for all the replies. I decided to just go for a clean re-install and wipe Win 11 completely from the system. Took 2 tries but I finally got back running again. It doesn't boot directly into Zorin though, it still gives the option to select Zorin / Advanced Options for Zorin / Windows Boot Manager / UEFI Firmware Settings.

I was really hoping it would boot directly into Zorin without that screen appearing and without the Windows Boot Manager thing.

Sorry, I'm really new at this stuff and struggling to make sense of it all.

That is your Grub Screen.
It is actually a good thing to see that and to have access to it. But you do have options.
You can set it to "hidden" and decrease the timeout. Do not set the timeout to 0 seconds, though as this may make it exceptionally difficult to pull up the grub menu when you need it in order to access the recovery menu.

With the Grub Menu set to "Hidden", you can still unhide it when you need to access it by tapping the esc or tab key at boot.

sudo nano /etc/default/grub

Ensure you are set to:

GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=5

Tap ctrl+o to overwrite, then enter to save current configuration. Tap ctrl+x to exit the editor.
Now you must run

sudo update-grub

for the changes to take effect.

With this now set up, let's look at your Bootloaders to see if Windows still is present in the bootloader, thereby causing Grub Menu to appear.
Run

efibootmgr

If you get a notice that it is not installed, just run

sudo apt install -y efibootmgr

Then run efibootmgr
You should see a list of bootloaders. It may look similar to:

BootOrder: 0000,0001,0002
Boot0000* Computer
Boot0001* Windows Boot Manager
Boot0002* ubuntu

If you see that Windows entry, remove it by looking at Boot0001* and grabbing that last digit: (in this example it is 1) and using that digit like this:

sudo efibootmgr -b 1 -B

If it was Boot0002*, then the command would be:

sudo efibootmgr -b 2 -B

Reboot and test...

@Aravisian
Thank you for these instructions. I made the changes to the grub file.. changed the GRUB_TIMEOUT_STYLE=hidden ... it still appears when rebooting.

I ran efibootmgr also and deleted two entries to Windows Boot Manager. It appears to work initially but when I reboot it's still there.

Post Re-Boot efibootmgr:

terminalWindow03

Your screenshot shows "Windows Boot Manager on /dev/nvme0n1p1"
Is that the same drive you have Zorin OS installed on?

I apologize for my extreme ignorance of Linux here... I only have one hard drive. I started out with it partitioned with Win11 on one small part and Zorin 16.3 on the rest of it. Got my Zorin desktop screwed which led me to reinstall and hopefully totally wipe Win11... So I'd say the answer to your question is yes but how could I tell for sure? Maybe the following is a clue.
TerminalWindow04

You're doing fine.
I am confused by what I am seeing, too. Your screenshot shows that you removed the Windows Bootloader- then the next command showed it as present. The third command didn't.

Are you willing to run

efibootmgr

then

sudo update grub

showing the output, again?

sure, No problem. REALLY appreciate your help...

Well it is showing Windows in both, again... can you run

sudo efibootmgr -b 1 -B

again and see if that changes?
If it does, run

sudo apt update

and ensure no windows is shown...

Yessir...

Now I'll reboot...

Here it is post reboot...
TerminalWindow07

The GRUB_TIMEOUT_STYLE=hidden change has taken effect. I guess it needed the sudo apt update to fix something there.
The entry for Windows Boot Manager is back as you can see in the efibootmgr.

In your BIOS, is Secure Boot disabled?
An Enabled Secure Boot can prevent changes to the efi partition.

Is Windows still installed? If Windows is installed elsewhere, it can and will repair its bootloader...

I disabled secure boot days ago before I started making changes to the OS. I also tried booting into windows from that initial startup screen the other day just to see what would happen and it just took me to the blue UEFI setup menu so I would say no, Windows is gone. I'll see if I can double check secure boot again...

secure boot is indeed disabled

Is the grub menu still not appearing at boot?

The only other thing I can think of is that Some Computers have firmware that restores the bootloader from a Recovery Partition. If Grub is not currently annoying you, I would just ignore the presence of the EFI bootloader for Windows.

The Grub menu is now hidden but I can pull it up by hitting esc at bootup.
I'm thinking your guess is correct since the last thing it does after I delete the entry for Windows Boot Manager and then execute
sudo update-grub is,,,
"Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsift/Boot/bootmhfw.efi
Adding boot menu entry for UEFI Firmware Settings"

I'll just run with it as is for now.
Thanks for all your help !! I definitely learned some things.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.