Settings app Crashes OS Everything Else Works

I just installed, every time i go in settings it crashes everything else works fine. i have reinstalled multiple times and i don't want to chose another os.

My Specs
AMD Ryzen 9 3900X
32.0 GB Ram
Kingston 500GB SSD
MSI RX 5500XT
MSI RX 5500XT

By this, do you mean the OS or the app for Settings?

If you mean the OS, then please try the terminal command:

sudo apt install --reinstall gnome-control-center

1 Like

still does it BTW i am referring
to the settings icon in the start menu

1 Like

Yes, that Settings app is named gnome-control-center as a package.
Can you run the following command in terminal, then immediately log out once it is complete and log back in and test if Settings crashes?

gsettings reset org.gnome.ControlCenter last-panel

1 Like

log out? or restart

1 Like

Either will work. Whichever you prefer.

1 Like

Still doesn't work

1 Like

hmmm...

Try

dconf reset -f /org/gnome/control-center/

1 Like

Still doesn't work, I don't know what the rules of the fourm are or if you want to I could TeamViewer

sudo apt install gnome-tweaks

Then, open Tweaks from the menu. Click on the Extensions option in the left pane. Then disable all extensions. Launch Settings and see if it crashes.

1 Like

I just made another discovery, I installed TeamViewer and then when I clicked it to launch it from the menu the os crashed

2 Likes

Can you check the contents of /var/crash for any crash logs?

Post the terminal output of journalctl -b -1 -e or use PasteBin to post it here, please.

1 Like

There is nothing in that directory

1 Like

Graphics glitches / freeze-up with new comp, ERROR: ring gfx timeout - #5 by beankylla - Graphics & Display - Manjaro Linux Forum this sounds similar

Can you please follow the steps here:

Then once done:

sudo groupadd power

sudo usermod --groups power --append $USER

Are you experiencing other graphics glitching?
What is the output of:

sudo lshw -short | grep -i --color display

1 Like

/0/100/3.1/0/0/0 display Navi 14 [Radeon RX 5500/5500M / Pro 5500M]

`

You might check the oibaf drivers:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

1 Like

Still doesn't work

I am at a complete loss, at this point.

1 Like