Slow opening software

On Zorin 16 beta, I noticed 2 of the installed software take quite long time (~30 seconds) to open.

  1. KeepasXC (apt)
  2. Notepadqq (apt)
    I have exactly the same software on Mint Cinnamon which opens immediately after the icon is clicked. Does anyone notice such phenomenon?

Try open them via the terminal, there might be something.

Hi Storm,
Thank for your advice.

I tried opening keepassxc (apt package) and got the following error message:

Gtk-Message: 12:00:21.178: Failed to load module "canberra-gtk-module"

keepass eventually opened about 30 seconds after this error message.

Same thing happened for notepadqq (apt package).

I searched for "canberra" in Synaptic and it looked like this:

(sorry, it is in Japanese)

I don't think it's that slowing your two apps, but try with;

sudo apt install libcanberra-gtk-module

Thanks for letting us know about this issue @FrenchPress! We've found the source of the bug – which affected Qt-based apps like the ones you listed – and have fixed it in the latest software updates. Please note that you'll need to re-log in or restart your computer to apply the fix fully after installing the updates.

Thank you for your immediate action :grinning:
Yes, it is all fixed now!