"Software" no longer indicating anything

I have issues with "Software" (the SW installation tool represented by shopping bag icon).

I can run it and it will start ok. But whenever I select anything, any SW to see what it is or install it, etc., nothing will happen, it will just show the "busy" mouse icon and circle it forever with no results.

How can it be broken?

Can you please run:

sudo apt install --reinstall ca-certificates gnome-software

Launch Software & Updates from the app menu and in the first tab, ensure that Download From is set to "Main Server."

Once finished, perform a Hard Reboot of the computer (Completely off - wait a moment, then power on) and test if Software is now working correctly?

2 Likes

No, this did not help. It still shows mouse arrow waiting animation forever after I select any SW in Software windows.

It seems I have even more issues with software.
I cannot do this:

  • Open Zorin OS main menu,
  • browse to an app,
  • right click app entry,
  • select "details".
    => This also results in endless mouse cursor waiting animation.

I can confirm that apparently the last update did something to the software app. On my laptop everything stills works fine. But on my desktop when I select installed it shows nothing. I have restarted the computer a couple of times but installed still shows nothing. But the store part seems to be still working although I haven't needed to install anything so can't be sure that part is working.

Have you tried?

sudo apt clean && sudo apt autoremove

killall gnome-software

rm -r ~/.local/share/gnome-software
2 Likes

A-ha! That has cured Software and also "Details".

Thanks a lot, for me this is solved :slightly_smiling_face:

1 Like

Thanks dasjdoom! That solved my problem also. I do love being able to just copy and paste the command lines from this forum directly into terminal and watching it do it's magic.

2 Likes

I'll let you in for a little secret..

Guess we sometimes forget how the search function works. Seeing this topic, I searched for the same issue and found this;

Perhaps it makes a difference how you define the search value(s). But it was not my doing it was all this guy's work ->

image

Even though he's not here, he's still resolves the issue. Guess it's the same as StarTreker who could make you laugh even when he's not commenting.
I thought they did make a great pair/couple of tech workers. But hey, who am I to say, don't know the men that long.

But back to the topic, yeah, I also like to use the command line, but copying and pasting makes it a lot easier.

1 Like

I fixed a typo for you.

1 Like

Common, you surely are modest. Accept it that it was a good job done by you.

Seeing the reply's above, I guess you just forgot about it, but I understand there is so much done how can you remember, you will also have to know how to search.

I forget far more than I remember.:neutral_face:

My issue has been solved by you, which is great and I really appreciate your fast and helpful replies.

I wonder how we can now make Zorin OS immune against this issue so it won't show up again. Other than that, I'll return here to look up the commands again for fixing it.

Actually there was a little difference between the issues described.
You found a description saying that someone was not able to run Software at all, while I still could run (start) it, though without much use of it. Seeing that I'm not sure if both things are actually related to the same root cause.

But yes, doing some research first to check if there have been similar things reported is never a bad idea and I hope I'll keep this in mind next time(s).

2 Likes

Computing is... Complex. To use an understatement.

Sadly, there is no Operating System that can be made to be immune from issues. You can easily imagine the fleet of floor moppers chasing after the High Level Microsoft Excuctives slobbering and drooling over such a prospect.
If it existed, MacOS or Windows would definitely be immune.

This does not mean that there is nothing you can do, though.
IF a certain piece of software is being troublesome, you might be well-served to find a replacement for it.

I prefer Synaptic Package manager for the same purpose that Gnome-Software serves...

sudo apt install synaptic

The terminal also doesn't let me down.
Even with these, you will not be immune from troubles. But, you may experience less, or experience easier fixes. And you get to learn something new.

This is the command line that made gnome Software work again whenever it broke on my PC.

Yes, synaptic is well known to me and I already have installed it to check if browser Brave came in deb package or nor.

I like gnome Software for the feature to check unknown software and somehow get inspired to try something new, so it's sort of sad it does not work reliable.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.