Software slow install+update ( ZORIN OS 17 )

Are these speeds unusual for you?
(They are better than mine...)
If they are, have you performed the normal resetting of the router, power-cycling internet supply?

the speed is good but the issue is in the software downloading and uploading , even if it was unusual it should not give me this slow download in software

Let's try

sudo apt clean && sudo apt autoclean

rm -rf ~/.cache/gnome-software

sudo apt install --reinstall gnome-software

and see if that makes a difference.

1 Like

is this related to the issue ?
oh it's nvidia nvm let's see

1 Like

solved thanks for the help , but i do expect it to happen again

but i do have 2 other issues if you still awake
1 : can't find my gpu in ''the finals''
2 : when i press ctrl esc it dose not get me out of the game and i don't mean by that close the game i just want to see the taskbar

What is your output for terminal command


I notice in your previous screenshot, login is considered a missing package.
Libreoffice and libwayland-client, as well. Do you recall removing these?

actually i don't

1 Like

This is confusing... Your Nvidia-smi output shows the 525 driver in use. Gnome Software says it is not installed.
Plus missing packages...

Did you install fresh or use the Zorin OS upgrader to reach Zorin OS 17?

last thing i did is trying to fix

E: sub-process /usr/bin/dpkg returned an error code (1)

and i fixed it after typing multiple commands such as

sudo mv /var/lib/dpgk/info/* /var/lib/dpgk/info_silent

sudo apt-get -f install

sudo ethtool -s enp3s0 speed 100 duplex full autoneg on

sudo apt install --fix-broken

sudo dpkg --configure -a

i think none if these related to the issue but it's always good to know
i have downloaded zorion os 17 and it is the first zorin , maybe because i have been copying command and paste it hoping it willl fix my problems

Screenshot from 2024-02-09 08-59-08
i have talked to some ppl saying my /boot file is full and i want to extend it they told me write this command they got shocked after they saw i have like 53 file

Yes, that command will show the size and usage, but it won't extend the size of the partition. To do that, you must use a partition manager (GnuLinux / Zorin OS GParted or in Windows OS Windows Partition Manager) to resize the partition. The partition must have empty space adjacent to it; so resizing often means having to move other partitions around in order to make the empty space.

since i destroyed windows i don't have any other option but using gparted and..

It looks like /dev/sda1 has 58 available gigs.

In order to perform the action, You must boot into a LiveUSB and have the /dev/sda drive unmounted.

Once you are booted into LiveUSB and ensured that /dev/sda is unmounted (you can usually just mount or unmount the volume in your file manager), launch Gparted and on the /dev/sda1 partition, click it to select it, then click the delete partition button which looks like a minus sign (-)
The /dev/sda1 partition should show as free space. You can then right click the /boot partition /dev/sda4 and select resize and use the slider to resize it into that available free space.

1 Like

i connected my flash to the pc but

I cannot really see anything in this image.

sorry , i restarted pc and i can see the flash

1 Like

when i enter gparted it disappear and i can't do anything until i close gprated

I am sorry, what exactly disappears?

4.4 tb and the drives under it from (files) when i enter gparted

but can you please tell me what to do step-by-step
because i don't know how to unmount dev/sda drive and boot the system from

Booting from LiveUSb is the same step you took when you installed Zorin OS:

If following the above guide, you can stop at the portion of "Installing Zorin OS". You want to select Try Zorin from the LiveUSB grub menu.

Once booted, you can launch Gparted either from app menu or alt+F2


In gparted, click on the partition you want to manage.
If it is greyed out, you may need to unmount it. Launch the file manager in the Try Zorin demo and in the left pane of the file manager, look for the Volume Size of that partition listed. Click on the icon on the far right of it on that line to eject.

With it now unmounted, proceed with the steps from above;

...or the detailed steps here as reference: