Software Update Error

Greetings All !
started seeing this error message a few days ago,
checked online, and similar errors were reported back in 2017 as a bug in Gnome software update, but i have not found any newer source indicating that this is still an issue. has anyone else experienced this message when attempting to update through software manager ?
Thanks in advance for any input.
Cheers!
Screenshot from 2021-09-23 17-58-32

1 Like

I've had quite a few of those error messages so far. Since I'm a new Zorin user, I thought it was common, for some reason.

AFAIK, it goes away in 1 or 2 days, by itself.

I don't know what causes it or why it happens...

2 Likes

Several members have reported this. It's partly due to the inclusion of Snap and Flatpak. Sometimes, reinstalling gnome-software seems to resolve it.

2 Likes

it seems that updates eventually happen and it refreshes, but I noticed it happening after I removed some software that i didn't need from the "installed" tab/list.

2 Likes

Interesting... thanks for sharing this; I think it is the first report of this observation. It may be related.

2 Likes

excuse the 'n00b' question but, does it need to be removed before re-installed ?
i have synaptic installed , im checking that now as im new to that as well :blush:

1 Like

I have messed around with 'snap' so that may be it as well

1 Like

You can choose whichever:

sudo apt remove --purge gnome-software && sudo apt install gnome-software

Or

sudo apt install --reinstall gnome-software

3 Likes

Great! i will try that now , thank you !

1 Like

I can say this issue, in my experience, happens usually with some previous update in Software app and not with uninstalling something. However, updating may a be sort of an uninstall-then-reinstall thing, so it's related? :thinking:

I'll try your sugestion, @Aravisian

2 Likes

Keep in mind, sometimes a simple restart of the computer fixes update issues. I had an update issue on my Zorin system several days ago. I can't remember if it was the same error, but kind of looks like it. Anyways, all I did was restart and the error was gone and my system could update again.

Sometimes the simplest solution is the right one. So try the simplest, if that don't work, then you can go down the rabbit hole looking for the next available solution.

2 Likes

yep, tried restarting a few times, and still the same result , :frowning:

1 Like

Followed the commands, tried the first one, purge/reinstall,
restarted the machine,
same error but the number has changed,
image

Update:
restarted again, tried the update and no error ! will keep an eye on it.

Update:
no changes on system, message came back today :thinking:
ugghh.....

image

Update:
rebooted system again, refreshed updates, and no error again.
seems as though takes time and eventually the error appears again after a reboot. Will keep monitoring.
:beers:

4 Likes

What you describe is exactly what happens to me. Restarting does not solve the issue.

However, the problem seems to go away on its own, after 1 or 2 days. Whatever causes the issue gets solved somewhere, maybe new update information/files/dependencies...