Software Updater Crashed My System [AGAIN!]

A little over a year ago, I posted a new topic with the same issue. Software updater crashed my system.

This is the second time it's happened and I'm already beyond annoyed. I'm using Zorin OS 16 Pro and I'm always a bit skeptical applying updates since there's always a chance that the updates will completely destroy my system and put me on an hours long treadmill of trying to figure out how to recover.

I'm already a few hours into this one. Yesterday I applied updates and after some time, the screen went black/blank and there's a blinking cursor in the upper left hand corner, for hours. After restarting the laptop manually, I get a console mode login only.

After following some of the steps from my previous thread, doing apt update, dpkg --configure -a and so on, all the packages seem to be up to date but the graphical environment still won't start.

After reboot, I get the console based login only. Trying to start it manually give me a full white screen with a sad computer icon, with the unhelpful message that "something has gone wrong".

I've combed through output from journalctl, /var/log/Xorg*log and anywhere else I can think to look. I've looked in /etc/X11 to see if maybe some new config files were installed or something, but those files all seem to be the same. None have even been modified this year.

Can anyone give any advice on why the software updater has so managed to break my system yet again?

You may want to check what driver is installed for the graphics card: lshw -C display

I'm thinking the upgrade have you the latest graphics driver and you'll need to roll back to the previous one or use a grub parameter to see the gui, i could be wrong though.

This most recent upgrade included a kernel upgrade from the -76 to the -78.

Interestingly, another user has suggested it may have solved his issue...

@aaronnewsome , from the Grub Menu > Advanced Options for Zorin, can you try booting up from the earlier kernel and see if that allows you to reach the desktop?

I've tried the advanced options, previous kernels, rescue mode. Looks like gdm3 is missing and can't be installed. There's some circular unmet dependencies. Like gnome-shell breaks gnome-settings-daemon or something like that.

I'm running a backup now, which will take a while since it's about 1TB.

Very strange. What regional server are you on?

I am in US, Texas.

Here's what I'm finding.

/etc/X11/default-display-manager

/usr/sbin/gdm3

there is no /usr/sbin/gdm3.

apt install gdm3

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gdm3 : Depends: gnome-session-bin (>= 3.10) but it is not going to be installed
        Depends: gnome-settings-daemon (>= 3.24) but it is not going to be installed
        Depends: gnome-shell (>= 3.19.92) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

apt install gdm3 gnome-session-bin gnome-settings-daemon gnome-shell

Reading package lists... Done
Building dependency tree       
Reading state information... Done
gnome-session-bin is already the newest version (3.38.0-3ubuntu2+zorin1).
gnome-settings-daemon is already the newest version (3.38.1-3ubuntu3+zorin1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-session-bin : Breaks: gdm3 (< 3.37.90) but 3.36.3-0ubuntu0.20.04.4pop0~1627310541~20.04~1576174~dev is to be installed
 gnome-settings-daemon : Breaks: gdm3 (< 3.37.0) but 3.36.3-0ubuntu0.20.04.4pop0~1627310541~20.04~1576174~dev is to be installed
                         Breaks: gnome-shell (< 3.37.90) but 3.36.9-0ubuntu0.20.04.2pop1~1675101131~20.04~f26f2b1~dev is to be installed
 gnome-shell : Depends: mutter (>= 3.36.0) but it is not going to be installed
               Recommends: gnome-control-center (>= 1:3.25.2) but it is not going to be installed
               Recommends: ubuntu-session but it is not going to be installed or
                           gnome-session
E: Unable to correct problems, you have held broken packages.

At this point, I've been working on this since late into the night last night. Now that I have a backup, I'm ready to wipe the NVME boot disk and reinstall. I do take regular backups but full bare metal backups are time consuming so those aren't as frequent.

Since this has happened TWICE already, I've learned my lesson. No more updates unless I make a full bare metal backup just prior to updating. Super annoying and frustrating.

There's also this:

apt list --upgradable

Listing... Done
selinux-policy-default/scar,scar,scar 2:2.20221101-9volian1 all [upgradable from: 2:2.20190201-8]
selinux-policy-dev/scar,scar,scar 2:2.20221101-9volian1 all [upgradable from: 2:2.20190201-8]

apt install selinux-policy-default selinux-policy-dev

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 selinux-policy-default : Depends: libselinux1 (>= 3.4) but 3.0-1build2 is to be installed
                          Depends: libsemanage2 (>= 3.4) but it is not installable
                          Depends: libsepol2 (>= 3.4) but it is not installable
                          Depends: policycoreutils (>= 3.4) but 3.0-1 is to be installed
                          Depends: selinux-utils (>= 3.4) but 3.0-1build2 is to be installed
 selinux-policy-dev : Depends: checkpolicy (>= 3.4) but 3.0-1 is to be installed
                      Depends: policycoreutils (>= 3.4) but 3.0-1 is to be installed
                      Depends: policycoreutils-dev (>= 3.4) but 3.0-1build1 is to be installed
                      Depends: policycoreutils-python-utils (>= 3.4) but 3.0-1build1 is to be installed
                      Depends: selinux-utils (>= 3.4) but 3.0-1build2 is to be installed
E: Unable to correct problems, you have held broken packages.

I don't have any packages held.

dpkg --get-selections | grep held

is empty

Do you have Pop_OS (System 76) repos added?
It looks like you have added another distros repo, which is causing package conflicts.

I did have system76 nvidia drivers. As far as I know, it's the only way I can switch between nVidia graphics and Intel integrated graphics. I don't think Zorin can do this natively. I don't know if the repo was added or if the debs were installed manually. It's been over a year since it was done. Either way, I don't have any conflicts any more since the system was wiped and reinstalled.

I must requote what you posted:

These packages are pop0~...~dev 100% coming from the System76 repo. This explains the crashing.
You can remove the Pop_OS repository using Software & Updates > Other software tab.

One thing users can do is briefly add a repo from another distro in order to install a package they need, but then immediately remove that repo once finished so that it does not cause or create such conflicts.

Yes, Zorin OS can do this natively. You may have needed to change the Nvidia drivers. We have covered doing this on this forum many times.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.